If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add a generic hook to update page actions

VERIFIED DUPLICATE of bug 556069

Status

Fennec Graveyard
General
--
enhancement
VERIFIED DUPLICATE of bug 556069
8 years ago
8 years ago

People

(Reporter: Wladimir Palant, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
Right now, IdentityHandler.setPopupMessages() will call a bunch of methods to update built-in page actions when the identity pop-up shows up. Unfortunately, this isn't very helpful for page actions supplied by extensions. For now I resorted to extending IdentityHandler.show() but that's obviously a hack. Maybe an event could be fired on window/document from IdentityHandler.setPopupMessages() instead. That's something extensions could listen to.

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 556069
(Reporter)

Comment 2

8 years ago
Heh, I looked at that bug but didn't realize that it was complaining about the same problem...
dupe, v. :)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.