Status

()

Core
HTML: Parser
P1
critical
VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: Scott Billings, Assigned: rickg)

Tracking

({crash, top100})

Trunk
x86
Linux
crash, top100
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rtm++] fix in hand, URL)

Attachments

(3 attachments)

(Reporter)

Description

18 years ago
All ZDNet discussion forums tend to give Mozilla fits, but particularly this
forum (usually the most active).

The initial loading of the page takes a fairly considerable amount of time
(longer than Communicator 4.73 on the same system).

Comment 1

18 years ago
Wow. not only does it load slowly, it completely freezes Mozilla while it's
rendering. That is pretty bad. I'd say this might be an M18 blocker, but what do
I know..

Updated

18 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

18 years ago
The problem with this page is the <font> tags are nesting too deeply, and layout 
is slowing down at that depth. For proof, I've attached a version of the same 
page, with added </font> tag's. Now we load it pretty quicky.

Reassign to buster as a placeholder.
Assignee: rickg → buster
(Assignee)

Comment 3

18 years ago
Created attachment 17535 [details]
Much faster ZDNet page rewritten with closing </font> tags.

Comment 4

18 years ago
Created attachment 17807 [details]
original test case (end tags still missing)
(Assignee)

Comment 5

18 years ago
Created attachment 17819 [details] [diff] [review]
Patch to fix infinite loop in parser; it's only a part of this bug.
(Assignee)

Comment 6

18 years ago
Buster: this fixes the infinite loop in the parser, but doesn't fix the really 
slow layout portion. I think we need to fix the parser problem anyway.

Comment 7

18 years ago
Rickg's patch is a parser side fix only and it looks fine to me....

r=harishd
Status: NEW → ASSIGNED

Comment 8

18 years ago
sr=buster

Comment 9

18 years ago
I don't think this bug has gotten the attention it needs, so changing summary
and adding proper keywords.

PDT: this is a crash bug.  On page load, the app goes into an infinite loop and
the process must be manually killed.  This is also a very popular site; the
crash will happen on many if not all of the pages under www.forums.zdnet.com.
The fix is low risk and bounded to a very specific situation created by
malformed source.  Unfortuantely, this pattern of poor HTML usage is in common
usage.

No other work will get done to speed up layout for this malformed source case
for rtm.  So this bug is only about the hang in the parser.
Severity: normal → critical
Keywords: crash, top100
Priority: P3 → P1
Summary: Page Loads Slowly → Page Hangs on load
Whiteboard: [rtm+] r=harishd, sr=buster

Comment 10

18 years ago
this is rick's bug now.  I already have a separate perf bug about layout with a
deep frame tree.
Assignee: buster → rickg
Status: ASSIGNED → NEW

Comment 11

18 years ago
This bug is in candidate limbo.  We will reconsider this fix once we have a 
candidate in hand, but we can't take this fix before then.
(Assignee)

Comment 12

18 years ago
*** Bug 57889 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 13

18 years ago
r=harishd, sr=buster
Status: NEW → ASSIGNED
Whiteboard: [rtm+] r=harishd, sr=buster → [rtm+] fix in hand

Updated

18 years ago
Whiteboard: [rtm+] fix in hand → [rtm+][InLimbo-OOH] fix in hand
(Assignee)

Comment 14

18 years ago
Patch landed on trunk over the weekend.

Comment 15

18 years ago
PDT marking [rtm++]. This bug is now out of limbo and approved for checkin to
the branch. Please check in ASAP.
Whiteboard: [rtm+][InLimbo-OOH] fix in hand → [rtm++][InLimbo-OOH] fix in hand

Comment 16

18 years ago
grrrr...now that you KNOW what [InLimbo-OOH] means, why don't you delete that
from the status whiteboard when the bug comes out of limbo? :P

Removing it myself.
Whiteboard: [rtm++][InLimbo-OOH] fix in hand → [rtm++] fix in hand
(Assignee)

Comment 17

18 years ago
Done. Thanks PDT.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 18

18 years ago
all better -- chrisd
Status: RESOLVED → VERIFIED

Comment 19

18 years ago
To expand on previous comment. Page no longer crashes/hangs using 10/31 branch
and trunk builds.
You need to log in before you can comment on or make changes to this bug.