Manual checking for updates does not apply compatibility updates

VERIFIED FIXED in mozilla1.9.3a5

Status

()

defect
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: whimboo, Assigned: Unfocused)

Tracking

Trunk
mozilla1.9.3a5
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [rewrite])

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100415 Minefield/3.7a5pre (.NET CLR 3.5.30729)

Manual checking for updates in the new addons manager doesn't apply compatibility updates to disabled extensions. No errors visible.

Steps:
1. Install the DOM inspector with a recent Minefield build
2. Start the latest build from the addons manager branch
3. Check that DOMi is disabled
4. Open the context menu and check for updates

You will see that we check for updates but no compatibility update gets applied. DOMi is still disabled while it is working on trunk.

This bug is the UI part from bug 557956.
I couldn't reproduce that with those steps (DOMi isn't marked compatible with 3.7a5pre anyway), but this changeset should fix it. 

http://hg.mozilla.org/projects/addonsmgr/rev/772b96a2a84b

From what I could tell, refreshing the addons manager tab should have fixed this - this changeset just makes it so the compatibility changes will show up when they happen. Of course, that depends on the API doing what it should (including re-enabling it, if appropriate).
Whiteboard: [rewrite] → [rewrite][fixed-in-addonsmgr]
Assignee: nobody → bmcbride
Landed on trunk as a part of bug 554007
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Whiteboard: [rewrite][fixed-in-addonsmgr] → [rewrite]
Target Milestone: --- → mozilla1.9.3a5
Verified fixed with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100517 Minefield/3.7a5pre (.NET CLR 3.5.30729)

This kind of test is really hard to do because a lot of manual steps are needed. It would be great if we could cover it with an automated test. Blair or Dave, I would need your feedback for the best way.
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
Flags: in-litmus?
(In reply to comment #3)
> This kind of test is really hard to do because a lot of manual steps are
> needed. It would be great if we could cover it with an automated test. Blair or
> Dave, I would need your feedback for the best way.

Yea, tricky. I think I should be able to automate this with the mocking provider (working on that now) - will comment again here once I know more.
Flags: in-litmus? → in-litmus-
You need to log in before you can comment on or make changes to this bug.