Closed Bug 559839 Opened 10 years ago Closed 10 years ago

Failures in ajax test suites aren't counted

Categories

(Core :: DOM: Core & HTML, defect, major)

defect
Not set
major

Tracking

()

RESOLVED FIXED
mozilla1.9.3a5

People

(Reporter: Ms2ger, Assigned: Ms2ger)

References

Details

Attachments

(2 files)

These failures aren't counted because the ajax tests use their own copy of the test files. Patch attached to make them use the normal ones.

For an example of failures that were missed, see bug 558610.
Attachment #439538 - Flags: review?(sayrer)
And for good measure, remove the copies of the test harness.
Attachment #439539 - Flags: review?(sayrer)
Attachment #439538 - Flags: review?(sayrer) → review+
Attachment #439539 - Flags: review?(sayrer) → review+
Thanks.
Keywords: checkin-needed
Depends on: 561700
Probably best not to check this in until bug 561700 is fixed, since it's going to suddenly make every single M2 (justifiably, correctly) orange.
Where by "is fixed" I mean "or the cause is backed out, which it is now, so assuming these patches make it through the tryserver run that's going right now, oh, pretty pretty please someone check this bad boy in."
http://hg.mozilla.org/mozilla-central/rev/ea7e3f4f45d7
http://hg.mozilla.org/mozilla-central/rev/d06dc7394b02
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Thanks, I assume the removals are welcome.
But I would (have) preferred that you use stubs in the tests, as in bug 427500 patch Gv1a...
Depends on: 427500
Flags: in-testsuite+
Target Milestone: --- → mozilla1.9.3a5
Duplicate of this bug: 569579
there is still a copy of SimpleTest.js and TestRunner.js in the ajax source on mozilla-central:
http://mxr.mozilla.org/mozilla-central/source/dom/tests/mochitest/ajax/mochikit/tests/SimpleTest/
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.