If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Save file" dialog comes up *behind* "Download" dialog

RESOLVED WORKSFORME

Status

()

Core
XUL
P3
normal
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Braden, Assigned: Brian Ryner (not reading))

Tracking

Trunk
mozilla1.0
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
When initiating a file download, the "Save file" dialog comes up behind the
"Download" dialog.

Why can't the download dialog just go away?

Comment 1

17 years ago
I don't see this, could you please be more specific about steps to reproduce?
(Reporter)

Comment 2

17 years ago
Click on a hyperlink to a file that will need to be saved to disc (rather than
displayed in the browser). This prompts the "Download" dialog to come up, giving
you the option either to open the file or save it to disc. Selecting "Save to
disc" prompts the "Save file" dialog to appear. When that dialog appears, it
comes up behind the "Download" dialog, and it can't be brought to the front.

I'm using Sawfish, if that has anything to do with it.

Comment 3

17 years ago
Hmm. I'm using Sawfish too, but don't see this.  Probably related to other
settings.  ->bryner
Assignee: trudelle → bryner
(Assignee)

Comment 4

17 years ago
I don't see this either.  The download dialog stays open, yes, but the
filepicker window appears in front of it.  I also have no problem bringing
either of these windows to the front.
(Assignee)

Comment 5

17 years ago
changing to assigned to get off my new-bug radar, but tempted to mark WORKSFORME
unless I get some idea how to reproduce this.
Status: NEW → ASSIGNED

Comment 6

17 years ago
I'm seeing this too, so here's some info about my config:

Debian GNU/Linux 2.2
Helix-gnome latest
Sawfish

Sawfish config:
Focus behavior:
[Focus]Enter/Exit,dialog windows inherit the focus from their parent, (no) focus
when first displayed, (no) raise when focused.

Misc:
[Misc] Raise selected windows, Warp to selected windows

Placement:
Windows: Best-fit, Dialogs: centered-on-parent

(Assignee)

Comment 7

17 years ago
mozilla 0.9, sounds like it's impairing functionality
Target Milestone: --- → mozilla0.9
(Assignee)

Comment 8

17 years ago
pavlov, any ideas?
(Assignee)

Comment 9

17 years ago
blizzard might have some ideas on this too...
The fact that there's no raise on focus and no raise on first display makes me
think that is the cause.  At the same time, though aren't we using the gnome
hints to do proper z-ordering?
(Assignee)

Comment 11

17 years ago
Sorry, I'm going to have to move some of these bugs off to moz1.0 (is anyone
still seeing this problem?)
Target Milestone: mozilla0.9 → mozilla1.0
(Reporter)

Comment 12

17 years ago
I'm nolonger seeing this. I've upgraded my Sawfish version (to 0.36), so perhaps
this was a bug that was fixed there.

Marking WORKSFORME.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.