Closed Bug 559908 Opened 12 years ago Closed 12 years ago

Youtube enabler extension doesn't play any youtube videos on fennec 1.1b1

Categories

(Firefox for Android Graveyard :: General, defect)

Fennec 1.1
ARM
Maemo
defect
Not set
normal

Tracking

(blocking1.9.2 -, fennec1.1+)

VERIFIED WONTFIX
Tracking Status
blocking1.9.2 --- -
fennec 1.1+ ---

People

(Reporter: tchung, Unassigned)

Details

(Keywords: regression, Whiteboard: [MobFx1.1Betatestday])

Attachments

(1 file)

While enabling the youtube enabler extension on fennec 1.1b1, playing a video in youtube does not work.  It returns an error with no plugins found, and please upgrade.   This same result is shown when the youtube enabler is disabled or uninstalled.

Since the expected behavior i assume was youtube enabler playing videos on 1.1b1, then we would need to investigate if this is a flash, extension, or fennec bug.

Repro:
1) install fennec 1.1b1 04142010 build
2) override extension compatibility (if needed), and install youtube enabler extension.  then restart
3) visit youtube.com
4) pick any video and try to play it
5) Verify plugin not found error, and then switches to an "upgrade?" link to flash.

Expected;
- Enabling youtube enabler should allow users to view youtube videos on fennec 1.1b1

Actual:
- Enabling youtube enabler doenst do jack with youtube videos.
Whiteboard: [MobFx1.1Betatestday]
likely a regression from picking up the 1.9.2.4 oopp enabled settings off when this was built.   As a result, we may have broke youtube enabler.   Flagging for blocking-fennec and beta for drivers to decide.

but i'm impartial to minusing it, cause this feature does require a 3rd party extension to run flash; and plugins are disabled by default.
tracking-fennec: --- → ?
Keywords: regression
In about:config, you can also set plugin.disable to false to have plugins enabled on all sites.
On trunk (1.9.3), it is still working fine.

It seems to me a pretty major thing, because I think a lot of people still would want to see flash working.
blocking1.9.2: --- → ?
Component: Extension Compatibility → General
QA Contact: extension-compatibility → general
I'm confused. Fennec should not have OOPP enabled by default at all: the preference change to enable it by default was a Firefox-specific change made in browser/app/profile/firefox.js. Did Fennec make a similar change in their config?
There is no dom.ipc.plugins.enabled pref set at all in Fennec1.1b1 1.92 builds.
tracking-fennec: ? → 1.1+
I took a skim through the addon code, I don't see any obvious reason it would be affected by Lorentz changes...
This is working for me now. Can you try it again?
okay  this is what is going on.....


In 1.1b1 build 2, the youtube enabler addon is disabled for some reason.

This causes youtube to display its "Pluging not found" message.

I uninstall the addon, restarted, then reinstalled the addon, restarted.

Flash worked again.


Could this be some versioning problem in the mfinkle addon?
I didn't use the Youtube enabler extension. I used the plugin.disable=false pref to make flash work, when I encountered this problem.

But now it seems to be working for me on fennec1.1b1 build2 on the n900.
I'm not sure why it is working now.
I confirm with dougt's scenario in comment 7.  reinstalling the addon after installing this build is now working.   

also plugin.disable = false. 

not sure about mw22's scenario, that sounds different than what i reported originally here.
Just an update. I think we understand that the behavior is working as we have coded:
1. Start with Fennec 1.1a2pre and Youtube Enabler installed and working
2. Update Fennec to 1.1b1 (Youtube Enabler is disabled because it is not compat with 1.1b1). You should see an alert telling you some add-ons were disabled.
3. Allow Youtube Enabler to update (or uninstall and reinstall) and it will work.

This is normal for Fennec. There was some time during Fennec 1.1b1 testing that Youtube Enabler was not updated to support 1.1b1, so it stayed disabled. But it is now fixed on AMO.

Since the auto-update in Step 3 could take some time, we could force an auto-update right after app launch. Users will still need to restart Fennec, if a newer version of an add-on was found.

I'll attach a patch to do this if we want. I don't think we really need it because, now that Youtube Enabler has been version bumped, it should be getting updated very soon after someone updates to Fennec 1.1b1. In fact, users of Fennec 1.0.x can be updating to it now.
I think that this should be WONTFIX or WORKSFORME, myself. It's certainly morphed from the original report.
blocking1.9.2: ? → -
my thoughts now after Mark's explanation. 

although a nice workaround, i agree we should *not* take the patch--as we dont typically auto-update AMO-extension users on restart without their opt in. (which..its coming soon to a Firefox Addons Manager UI near you!)  plus we dont have an update checker on fennec right now anyway.. i dont think.

As long as we keep AMO updated, and a good relnote written about reinstalling the addon to get your videos back; i'm good for that.  Also, since we play to enable plugins in 2.0 anyway, this extension will very soon get obsolete.
Closing as WONTFIX
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → WONTFIX
ver.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.