Right clicking in a cell doesn't set selection correctly

VERIFIED FIXED in mozilla0.9.2

Status

()

Core
Editor
P3
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: sujay, Assigned: Charles Manske)

Tracking

({regression})

Trunk
mozilla0.9.2
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [behavior])

Attachments

(4 attachments)

(Reporter)

Description

18 years ago
using 10/10 build of netscape

1) launch netscape
2) launch composer
3) enter 5 x 5 table
4) click in a cell
5) right mouse click to bring up context menu
6) select Join Cell option

notice it doesn't join cell....maybe its not redrawing...

Join cell does work from Table menu.

Comment 1

18 years ago
cmanske, future.
Assignee: sfraser → cmanske
Target Milestone: --- → Future

Comment 2

18 years ago
Should this be release noted for RTM, or is it too minor a bug to document?

If the verdict is to add this to release notes, what's the recommended 
workaround?

Comment 3

18 years ago
nominate this bug to be fixed before mozilla 1.0; we should either fix this
context menu item to work or remove it from the context menu.
Target Milestone: Future → mozilla0.9
(Assignee)

Comment 4

18 years ago
Original bug claimed 'Join cells' didn't work. That's not the problem. The
problem is that when you right-click on an empty cell, the selection is lost,
thus "Join cells" (or many other table commands) don't work. What should happen:
The caret (collapsed selection) should be set to the beginning of the cell
contents before the popup menu appears.
Status: NEW → ASSIGNED
Summary: join cell doesn't appear to work from context menu → Right clicking in a cell doesn't set selection correctly
(Assignee)

Comment 5

18 years ago
Created attachment 21860 [details] [diff] [review]
Fix for bug.
(Assignee)

Comment 6

18 years ago
Problem was that when right clicking in an empty cell, the mouse event "target"
element is the cell itself instead of the usual textnode or other content of cell.
We were selecting the cell in that case when we really just want to put caret
(collapse the selection) into that cell.
(Assignee)

Comment 7

18 years ago
Selection is collapsed to beginning of cell right-clicked in.

Comment 8

18 years ago
Replacing kristif with robinf. Robin Foster is now the doc contact for Composer
(Assignee)

Comment 9

18 years ago
checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 10

17 years ago
reopening bug; this does not work if the cell is empty (has no text or only br's)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla0.9 → mozilla0.9.1
(Assignee)

Comment 11

17 years ago
It doesn't seem to work period, even with cell contents. Must have regressed
because of other changes in that code.
Status: REOPENED → ASSIGNED
(Assignee)

Comment 12

17 years ago
Created attachment 31486 [details] [diff] [review]
Fixed testing if mouse click is in selection.
(Assignee)

Comment 13

17 years ago
The problem was in the loop which tests if the point clicked on is within the
selection range(s). Once a range is found, we must exit loop. When there are
multiple cells selected, we were erroneously concluding that we weren't clicking
in the selection.
Keywords: patch, review
Whiteboard: FIX IN HAND need r=, sr=

Comment 14

17 years ago
sr=kin@netscape.com
Whiteboard: FIX IN HAND need r=, sr= → FIX IN HAND need r=

Comment 15

17 years ago
r=akkana
(Assignee)

Comment 16

17 years ago
checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago17 years ago
Keywords: patch, review
Resolution: --- → FIXED
Whiteboard: FIX IN HAND need r=
(Reporter)

Comment 17

17 years ago
still not working using 6/4 build.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 18

17 years ago
I don't consider this a 9.1 stopper - can we move this to 9.2?
(Assignee)

Comment 19

17 years ago
Who busted this! It used to work!
Status: REOPENED → ASSIGNED
Target Milestone: mozilla0.9.1 → mozilla0.9.2

Updated

17 years ago
Keywords: correctness, regression
Whiteboard: [behavior]
(Assignee)

Comment 20

17 years ago
Created attachment 37568 [details] [diff] [review]
Fixes case where of click selecting a single cell
(Assignee)

Comment 21

17 years ago
The final problem was that context click on a cell auto-selects the cell
if you click past the end of existing content or cell is empty (you
don't actually see the cell selection hightlightin, no sure why! But it
doesn't really matter when context popup is used; it shows after you are done.)
The "JoinTableCells" command didn't do anything if just one cell was selected,
but we should join with cell to right in that case. Simple fix -- just check
if there's a second cell selected.
Keywords: patch, review
Whiteboard: [behavior] → [behavior] FIX IN HAND need r=, sr=

Comment 22

17 years ago
sr=kin@netscape.com with the one change I suggested on AIM.
(Assignee)

Comment 23

17 years ago
Created attachment 37584 [details] [diff] [review]
Update with kin's suggested change
(Assignee)

Updated

17 years ago
Whiteboard: [behavior] FIX IN HAND need r=, sr= → [behavior] FIX IN HAND need r=

Comment 24

17 years ago
r=mjudge
(Assignee)

Comment 25

17 years ago
checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
Whiteboard: [behavior] FIX IN HAND need r= → [behavior]
(Reporter)

Comment 26

17 years ago
verified in 6/18 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.