[OOPP]Firefox crashes with C++ Runtime Error

RESOLVED DUPLICATE of bug 559943

Status

()

Core
Plug-ins
--
critical
RESOLVED DUPLICATE of bug 559943
8 years ago
8 years ago

People

(Reporter: kuvik3, Unassigned)

Tracking

({crash})

1.9.2 Branch
x86_64
Windows 7
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.3pre) Gecko/20100405 Firefox/3.6.3plugin1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.3pre) Gecko/20100405 Firefox/3.6.3plugin1

Go to the site and start playing the Silverlight video. Right-click on it and then left-click outside of video. Firefox hangs and do one of these:
- OOPP catches the crash of Silverlight Plagin
- Message appears saying "C++ Runtime Error"
- Breakpad catches the error (one of these three):
http://crash-stats.mozilla.com/report/index/54be2bab-e8e7-4284-8f43-3a5f72100416
http://crash-stats.mozilla.com/report/index/fc6dcf5f-5bee-4b37-aa23-3ebad2100416
http://crash-stats.mozilla.com/report/index/2c9de42b-144d-4d58-801f-6d4a52100416

Reproducible: Always
Component: General → Plug-ins
Keywords: crash
Product: Firefox → Core
QA Contact: general → plugins
Summary: Firefox crashes with C++ Runtime Error → {OOPP]Firefox crashes with C++ Runtime Error
Version: unspecified → 1.9.2 Branch

Comment 1

8 years ago
Would you check if the build at https://bugzilla.mozilla.org/show_bug.cgi?id=559597#c7 stops your crashing. It has a fix for a bug that causes Silverlight crashes.
(Reporter)

Comment 2

8 years ago
Still crashes with that build.

Comment 3

8 years ago
the first signature is a bug i'm working on, my tree has a fix.
Summary: {OOPP]Firefox crashes with C++ Runtime Error → [OOPP]Firefox crashes with C++ Runtime Error
using Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.4) Gecko/20100413 Firefox/3.6.4 ID:20100413172113 + Silverlight 4 npctrl.dll Version: 4.0.50401.0
and the STR from comment 0 i get two [@ KiFastSystemCallRet] crashes (Bug 558647 ?) only and no C++ Runtime Error.

bp-773e10a6-8626-4b3c-8679-7dbc82100418
bp-fd1fe0c3-f31c-45fe-b537-183702100418

so maybe it's a Win7 only issue ...

Comment 5

8 years ago
Signature	KiFastSystemCallRet
UUID	773e10a6-8626-4b3c-8679-7dbc82100418
Time 	2010-04-18 03:47:47.546838
Uptime	81
Product	Firefox
Version	3.6.4
Build ID	20100413172113
Branch	1.9.2
OS	Windows NT
OS Version	5.1.2600 Service Pack 3
CPU	x86
CPU Info	GenuineIntel family 15 model 2 stepping 9
Crash Reason	EXCEPTION_BREAKPOINT
Crash Address	0x1055b431
User Comments	
Processor Notes 	

Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	ntdll.dll 	KiFastSystemCallRet 	
1 	ntdll.dll 	ZwWaitForSingleObject 	
2 	kernel32.dll 	WaitForSingleObjectEx 	
3 	kernel32.dll 	WaitForSingleObject 	
4 	xul.dll 	google_breakpad::ExceptionHandler::WriteMinidumpOnHandlerThread 	toolkit/crashreporter/google-breakpad/src/client/windows/handler/exception_handler.cc:691
5 	xul.dll 	google_breakpad::ExceptionHandler::WriteMinidumpForException 	toolkit/crashreporter/google-breakpad/src/client/windows/handler/exception_handler.cc:706
6 	xul.dll 	google_breakpad::ExceptionHandler::WriteMinidump 	toolkit/crashreporter/google-breakpad/src/client/windows/handler/exception_handler.cc:748
7 	xul.dll 	CrashReporter::CreatePairedMinidumps 	toolkit/crashreporter/nsExceptionHandler.cpp:1704
8 	xul.dll 	mozilla::plugins::PluginModuleParent::ShouldContinueFromReplyTimeout 	dom/plugins/PluginModuleParent.cpp:226
9 	xul.dll 	mozilla::ipc::SyncChannel::ShouldContinueFromTimeout 	ipc/glue/SyncChannel.cpp:258
10 	xul.dll 	mozilla::ipc::RPCChannel::Call 	ipc/glue/RPCChannel.cpp:214
11 	xul.dll 	mozilla::plugins::PPluginScriptableObjectParent::CallHasProperty 	obj-firefox/ipc/ipdl/PPluginScriptableObjectParent.cpp:454
12 	xul.dll 	mozilla::plugins::PluginScriptableObjectParent::ScriptableHasProperty 	dom/plugins/PluginScriptableObjectParent.cpp:310
13 	xul.dll 	NPObjWrapper_NewResolve 	modules/plugin/base/src/nsJSNPRuntime.cpp:1648
14 	js3250.dll 	js_LookupPropertyWithFlags 	js/src/jsobj.cpp:3800
15 	js3250.dll 	js_GetPropertyHelper 	js/src/jsobj.cpp:4191
16 	js3250.dll 	js_Interpret 	js/src/jsops.cpp:1520
17 	js3250.dll 	js_Invoke 	js/src/jsinterp.cpp:1368
18 	js3250.dll 	js_fun_apply 	js/src/jsfun.cpp:2046
19 	js3250.dll 	js_Interpret 	js/src/jsops.cpp:2208
20 	js3250.dll 	js_Invoke 	js/src/jsinterp.cpp:1368
21 	xul.dll 	nsXPCWrappedJSClass::CallMethod 	js/src/xpconnect/src/xpcwrappedjsclass.cpp:1696
22 	xul.dll 	nsXPCWrappedJS::CallMethod 	js/src/xpconnect/src/xpcwrappedjs.cpp:570
23 	xul.dll 	PrepareAndDispatch 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:114
24 	xul.dll 	SharedStub 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:141
25 	xul.dll 	nsEventListenerManager::HandleEventSubType 	content/events/src/nsEventListenerManager.cpp:1041

In theory there's supposed to be a paired stack trace. for this, and note that this is a plugin hang detector, not the 'c++ runtime error' described in your summary.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 559943
You need to log in before you can comment on or make changes to this bug.