Closed Bug 559939 Opened 13 years ago Closed 12 years ago

HTML5 <video> container should have a context menu on Fennec (mobile)

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: Tobbi, Assigned: aaronmt)

References

Details

(Whiteboard: [MobFx1.1Betatestday])

Attachments

(1 file)

When opening a HTML5 video site with current trunk build of Fennec, I found out that it has no context menu at all.

This is a difference to Firefox, where the context menu contains items like Play, Pause, Restart, Full Screen, Copy video URL, and much more.

I think it should be available on Fennec too (at least the most important of them, keeping in mind that space is limited on mobile)
We can't really fix the context menu issue until we have controls for the feature, so I'm marking this as dependent on the bug mentioned in comment #2
Depends on: 465839
Attached patch part 1Splinter Review
As a start, this adds a context menu for video elements with "Share Video" and "Save Video" commands:
http://mxr.mozilla.org/mozilla-central/source/browser/base/content/nsContextMenu.js#806

We could add Play/Pause, but it would require a little extra code to send messages back to the child process.  I haven't done this yet because Madhava suggested just using single-tap for play/pause.

It looks like full-screen needs more code too.  Firefox uses an HTML page and openDialog to do full-screen:
http://mxr.mozilla.org/mozilla-central/source/browser/base/content/nsContextMenu.js#807
Assignee: nobody → mbrubeck
Status: NEW → ASSIGNED
Attachment #469148 - Flags: review?(mark.finkle)
Comment on attachment 469148 [details] [diff] [review]
part 1

This is a good start.
Attachment #469148 - Flags: review?(mark.finkle) → review+
Filed followup bug 590719 for play/pause and bug 590715 for fullscreen.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
verified FIXED on builds:

Mozilla/5.0 (X11; U; Linux armv71; Nokia N900; en-US; rv:2.0b5pre) Gecko/20100826 Namoroka/4.0b5pre Fennec/2.0a1pre

and

Mozilla/5.0 (Android; Linux armv71; Nokia N900; en-US; rv:2.0b5pre) Gecko/20100826 Namoroka/4.0b5pre Fennec/2.0a1pre
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
Flags: in-litmus?
Assignee: mbrubeck → aaron.train
https://litmus.mozilla.org/show_test.cgi?id=12895
Flags: in-litmus? → in-litmus+
Duplicate of this bug: 611587
You need to log in before you can comment on or make changes to this bug.