Phonedog.com hangs the browser with D2D enabled

RESOLVED WORKSFORME

Status

()

Core
Graphics
--
critical
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: Anders G. Jørgensen, Assigned: bas)

Tracking

Trunk
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100417 Minefield/3.7a5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a5pre) Gecko/20100417 Minefield/3.7a5pre ID:20100417040211

The browser hangs when going to phonedog.com. This only happens when D2D is enabled.

Reproducible: Always

Steps to Reproduce:
1. Go to phonedog.com
2. Wait about 10 secs
Actual Results:  
The browser hangs, but I can close the window.

Expected Results:  
I should be able to view the page.

I was able to crash the browser one time. Here is the report: http://crash-stats.mozilla.com/report/index/bp-022d49a4-0b4e-4193-8768-969852100417
(Reporter)

Updated

8 years ago
Blocks: 549116
Version: unspecified → Trunk
(Assignee)

Comment 1

8 years ago
Created attachment 439741 [details] [diff] [review]
More thoroughly check scroll parameters

This page seems to get us messed up scrolling parameters. This patch deals with those parameters. On the long run we should probably still figure out why we get those parameters.
Assignee: nobody → bas.schouten
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #439741 - Flags: review?(jmuizelaar)
(In reply to comment #1)
> Created an attachment (id=439741) [details]
> More thoroughly check scroll parameters
> 
> This page seems to get us messed up scrolling parameters. This patch deals with
> those parameters. On the long run we should probably still figure out why we
> get those parameters.

Can we figure out why in the short term?
(Assignee)

Comment 3

8 years ago
(In reply to comment #2)
> (In reply to comment #1)
> > Created an attachment (id=439741) [details] [details]
> > More thoroughly check scroll parameters
> > 
> > This page seems to get us messed up scrolling parameters. This patch deals with
> > those parameters. On the long run we should probably still figure out why we
> > get those parameters.
> 
> Can we figure out why in the short term?

We should, I might note this seems to happen outside of D2D as well.
I'm not seeing this behavior with Minefield Build 20100506040636. Win 7 Pro x64, ATI Radeon 5870, latest 10.4 driver release. OOPP=on, HTML5=on, D2D=on, DW=on. Phonedog.com loads fine, scrolls up and down fine, browsed multiple pages on the site, no hangs, crashes, etc.
(Assignee)

Comment 5

8 years ago
Jeff, can we land the more solid parameter checking in D3D atleast? :)
I just tested this site with latest trunk and Nvidia 7150 32bit Win7 and I cannot get it to crash or hang with D2D/DW/OOPP/HTML5 enabled.  Could not reproduce.
(Assignee)

Updated

8 years ago
Blocks: 569166
(Assignee)

Updated

8 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.