default video dimensions do not follow standard

RESOLVED FIXED

Status

()

Core
Audio/Video
--
trivial
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Silvia Pfeiffer, Assigned: Ms2ger)

Tracking

({regression})

unspecified
regression
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(blocking2.0 beta1+, blocking1.9.2 -, status1.9.2 wanted)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_2; en-us) AppleWebKit/531.22.7 (KHTML, like Gecko) Version/4.0.5 Safari/531.22.7
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

I noticed that http://www.whatwg.org/specs/web-apps/current-work/multipage/video.html#video says that the default dimensions of <video> are 300px by 150px, but Firefox seems to do 300px by 28px when loading of video src and of poster fail.

Example page:

<!DOCTYPE html>
<html lang="en">
  <head>
    <title>Test</title>
  </head>
  <body>
      <video src="HelloWorld.ogv">
      </video>
  </body>
</html>


Reproducible: Always

Steps to Reproduce:
1. Use above example page and load into Firefox (I did it from localhost)

Actual Results:  
Dimensions are 300px x 28px

Expected Results:  
Dimensions should be 300px x 150px according to standard
Component: General → Video/Audio
Product: Firefox → Core
QA Contact: general → video.audio
This seems to be fallout from bug 449156: the intrinsic height seems to be set to the height of the controls instead of to 150.  We should be treating the "not a video element" and "video element but has no video data" cases differently in this code instead of taking the same codepath for both....
Blocks: 449156
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Not sure whether we should fix this on 1.9.2, but definitely should on trunk.
blocking1.9.2: --- → ?
blocking2.0: --- → ?
Not sure it's essential to fix on 1.9.2 either, but if the patch is an easy backport, we'd likely take it.
blocking1.9.2: ? → -
status1.9.2: --- → wanted
blocking2.0: ? → beta1+
(Assignee)

Comment 4

8 years ago
Created attachment 451091 [details] [diff] [review]
Patch v1
Assignee: nobody → Ms2ger
Status: NEW → ASSIGNED
Attachment #451091 - Flags: review?(roc)
Attachment #451091 - Flags: review?(roc) → review+
(Assignee)

Updated

8 years ago
Keywords: checkin-needed
http://hg.mozilla.org/mozilla-central/rev/d47f849195a2
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.