My Facebook "javascripts" won't work even if site is whitelisted in Noscripts and ABP

RESOLVED FIXED

Status

()

Firefox
General
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Warpath, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 GTB7.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 GTB7.0

This only affect facebook and no other sites, JS seem to work fine on other sites but only affects facebook

The problems:
* Can't share "what's on your mind" because the "Share" button even if clicked does nothing
* Chat doesn't work either since I can't click any names on the left to open a chatbox and instead it opens their profile page (the chat box in the bottom right doesn't even work)
* If there is a notification (Red number), it does open the sub-menu and allows you to click to the update but the number stays, it doesn't go away
* Can't "Like" comments because clicking it does nothing  and though clicking the "comment" button next to it opens a box, pressing the comment button after making a comment does nothing
* When you type in the "Search" bar, it should give hints but it does nothing for me even though it allows you to search


Note:
I have AdBlockPlus and NoScript and they are not affecting it.
They are all whitelisted and disabled on facebook so they are not the ones causing problem.
I have already tried "safemode" but the problem is still there.
There are no errors in the error console but there are a few warnings:

"Warning: Expected declaration but found '*'.  Skipped to next declaration.
Source File: http://static.ak.fbcdn.net/rsrc.php/z64OR/hash/5yzvcbi3.css
Line: 473"

"Warning: Expected declaration but found '*'.  Skipped to next declaration.
Source File: http://static.ak.fbcdn.net/rsrc.php/z6IDJ/hash/51fhgmma.css
Line: 104"

"Warning: Unknown property 'zoom'.  Declaration dropped.
Source File: http://static.ak.fbcdn.net/rsrc.php/z9SWR/hash/edkb2lyi.css
Line: 119"

Reproducible: Always




My add-ons/Extensions (note: I have had all these even before the problem started)

AdBlockPlus 1.1.3
AFOM 2.0
Chatzilla 0.9.8.6
Google toolbar 7.020100326W
Java Console 6.0.17
No Script 1.9.9.63
Orbit downlaoder integration 2.02
ShowIp 0.8.19
Tineye reverse Image search 0.7.1
(Reporter)

Comment 1

8 years ago
ok, it seems it somehow collides with the Java plugin (Add-on) and disabling that resolves the issue as per blocklist (https://www.mozilla.com/en-US/blocklist/) as per bug 558584
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.