my third problem with nsIExtensionManager

RESOLVED INVALID

Status

RESOLVED INVALID
9 years ago
4 months ago

People

(Reporter: pedbessa, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pt-BR; rv:1.9.1.9) Gecko/20100401 Ubuntu/9.10 (karmic) Firefox/3.5.9 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; pt-BR; rv:1.9.1.9) Gecko/20100401 Ubuntu/9.10 (karmic) Firefox/3.5.9 (.NET CLR 3.5.30729)

When I was developing a Firefox addon called Site Compare, I selected my addon folder with nsIExtensionManager, then opened a file there, then read it line-by-line, but each line didn't have a charAt method, then I took a path which I didn't use nsIExtensionManager to develop my addon and now it works.

When I was installing a bookmark extension called MyBookmarks, it wouldn't install, because of an error -203, then I double-clicked it in the Error Console and it was coming from nsIExtensionManager. (That error doesn't exist any longer, because I can use MyBookmarks.)

*Now, I created a profile, then opened it, then installed Extension Developer's Extension, then enabled debugging, then tried to create two xpi files with it, one from the source code of an addon that I'm developing and one from the source code of Site Compare v0.87, an addon that is in Mozilla Addons, that works, but in both situations I opened the Error Console, then I got lots of error messages, then I double-clicked one of them and it was a small method that used nsIExtensionManager.*

Reproducible: Always

Steps to Reproduce:
1. create an empty profile
2. open it
2. install Extension Developer's Extension in it
3. enable debugging in the Extension Developer's menu item
4. try to create a xpi file from the Site Compare v0.87 source code ( http://www.2shared.com/file/12648556/7e7d6d6b/sitecompare_v087.html ) or the Missing Alert source code ( http://www.2shared.com/file/12648571/d22f9a4a/missing_alert.html )
Actual Results:  
In the Error Console, there are lots of error messages.

Expected Results:  
The xpi file would be created.

Comment 1

9 years ago
Since you don't actually list any of the error messages you complain about we can't help you. And since this problem appears to be related to the EDE extension - and older extension now superseded by the online extension wizard - perhaps you should complain to the author of that extension.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

9 years ago
Created attachment 439812 [details]
This is what I saw, the lots of error messages.

When trying to create an xpi file with Extension Developer's Extension, this is what I saw, the lots of error messages, in the Error Console.
(Reporter)

Comment 3

9 years ago
The first problem:
http://stackoverflow.com/questions/2393262/alertline-alerts-ac-and-typeofline-is-string-but-charat-is-not-a-functio

The second problem:
https://bugzilla.mozilla.org/show_bug.cgi?id=555541

The third problem:
an attachment, in my previous post

Can you help me now?
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 4

9 years ago
> Created an attachment (id=439812) [details]
> This is what I saw, the lots of error messages.

The first error comes from teh ubuntufox extension which comes with your ubuntu distro. Please file a bug in their launchpad bug reporting system there instead.

The rest are errors from the Extension Developers Extension. Please get support from the author. We are not responsible for these errors.

> The first problem:
> http://stackoverflow.com/questions/2393262/alertline-alerts-ac-and-typeofline-is-string-but-charat-is-not-a-functio

Bugzilla is not a tech support forum. Please go to news://news.mozilla.org/mozilla.dev.extensions or irc://moznet/extdev for your tech support questions.

> The second problem:
> https://bugzilla.mozilla.org/show_bug.cgi?id=555541

This problem is being dealt with in the respective bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → INVALID
(Reporter)

Updated

7 years ago
Severity: major → normal

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.