Closed Bug 560159 Opened 10 years ago Closed 9 years ago

Trojan virus hitting my Firefox update.

Categories

(Firefox :: General, defect, critical)

x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED INCOMPLETE

People

(Reporter: b1nora732, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [CLOSEME 2011-1-30])

User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; GTB0.0; InfoPath.1; .NET CLR 1.1.4322)
Build Identifier: 

I downloaded firefox onto an older computer after my newer Vista computer crashed. After the download which was the only program that was ran on this computer that day a trojan virus hit my PC. The only thing that saved this computer was an awesome firewall my brother-in-law had set up. However, it seemed to piggy back onto your program since your site was the only one that I was on or downloaded the day it got hit. 

The last time I loaded Firefox the program actually didn't even load my homepage of Bing.com and instead loaded a recreational software website that I have never heard of before. 

Reproducible: Didn't try

Actual Results:  
Did not want to try to reproduce because of the fragility of the computers OS.
Sounds like you have malware on your computer:
http://support.mozilla.com/en-US/kb/Searches+are+redirected+to+another+site#All_searches_are_affected

You also mentioned your computer crashed before you installed Firefox.  This could have been the point when the malware was installed, or it could have been on there previously.  Assuming you downloaded your copy of Firefox from Mozilla, e.g. http://mozilla.com/firefox, we can say with high confidence that the Firefox installer did not put the malware on your system.
Group: core-security
We would also need more details on which malware package was installed, and which anti-virus packages are able to detect problems on your system.
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles

You can also try to reproduce in Firefox 4 Beta 8 or later, there are many improvements in the new version, http://www.mozilla.com/en-US/firefox/all-beta.html
Whiteboard: [CLOSEME 2011-1-30]
No reply, INCOMPLETE. Please retest with Firefox 3.6.13 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.