lightning worked well then after restart did not load with thunderbird (NS_ERROR_FAILURE) [mozIStorageConnection.executeSimpleSQL]

RESOLVED DUPLICATE of bug 558034

Status

Calendar
Provider: Local Storage
RESOLVED DUPLICATE of bug 558034
8 years ago
8 years ago

People

(Reporter: peter, Unassigned)

Tracking

Lightning 1.0b1
x86
Windows 7

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.5) Gecko/20091102 Firefox/3.5.5
Build Identifier: lightning-1.0b1+tb+sm-win.xpi

I performed the upgrade to Thunderbird 3 and the Lightning upgrade at the same time. It all went well and Lightning installed and all functions worked. This is on Win7 Pro OS. After I restarted the laptop lightning did not load with Thunderbird and all calendar entries appear to have been lost.

I dual boot this machine with Ubunto 9.10 and use the same email and calendar  for both OS's. i.e. I have a partition on te computer that houses all of my commonnly used data and both Win and Ubuntu use the same files for both email and calendar. It is such a nice thing to be able to access a common email and calendar from both OS's.After I lost? lightning for Win7 I rebooted into Ubuntu to check if any changes had occurred there. Whatever change has occurred with the upgrade now prevents me from accessing Lightning when in Ubuntu as well.

Reproducible: Always

Steps to Reproduce:
1.Sorry I've no idea how it happenned
2.
3.


Expected Results:  
Lightning installs and is accessible after reboot.
(Reporter)

Comment 1

8 years ago
An error was encountered preparing the calendar located at moz-profile-calendar://for use. It will not be available

Error Code: 0x80004005

[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [mozIStorageConnection.executeSimpleSQL]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///C:/Users/Seedsman%20Consulting/AppData/Roaming/Thunderbird/Profiles/jic0zhnq.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///C:/Users/Seedsman%20Consulting/AppData/Roaming/Thunderbird/Profiles/jic0zhnq.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calStorageCalendar.js :: anonymous :: line 220"  data: no]
Please check the following blog posts:

http://weblogs.mozillazine.org/calendar/2009/11/getting_a_database_error_in_yo.html

http://weblogs.mozillazine.org/calendar/2009/11/10_beta_1_is_one_step_closer.html

Updated

8 years ago
Component: General → Provider: Local Storage
QA Contact: general → storage-provider
Summary: lightning worked well then after restart did not load with thunderbird, → lightning worked well then after restart did not load with thunderbird (NS_ERROR_FAILURE) [mozIStorageConnection.executeSimpleSQL]
Version: unspecified → Lightning 1.0b1
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 558034
You need to log in before you can comment on or make changes to this bug.