unable to delete newsgroup saved search

RESOLVED FIXED in Thunderbird 30.0

Status

Thunderbird
Folder and Message Lists
RESOLVED FIXED
8 years ago
4 years ago

People

(Reporter: glob, Assigned: aceman)

Tracking

unspecified
Thunderbird 30.0
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

5.25 KB, patch
aceman
: review+
Details | Diff | Splinter Review
(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.2) Gecko/20100316 Firefox/3.6.2 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.9) Gecko/20100317 Thunderbird/3.0.4

i am unable to delete a newsgroup filtering saved search.

there is no option to delete the saved search in the context menu, and clicking 'unsubscribe' does nothing.

Reproducible: Always

Steps to Reproduce:
1. search a newsgroup
2. create a saved search from the results
3. right-click on the search and look for 'delete'

Actual Results:  
no delete option

Expected Results:  
the ability to delete saved searches
Anything in Tools -> error console ?
(Reporter)

Comment 2

8 years ago
nothing in the error console.

should there be a "delete" item in the context menu?

Comment 3

8 years ago
I believe the issue is that we don't allow delete of newsgroups, and because the saved search is under a news server, we mistakenly think it's a newsgroup and don't allow delete of it.
(Reporter)

Comment 4

8 years ago
until this bug is resolved, is there a way to manually delete the searches?
(Assignee)

Comment 5

5 years ago
You can manually remove it from the file virtualFolders.dat in your TB profile.

If this is just a wrong condition in the context menu as comment 3 suggests, I can try this.
Assignee: nobody → acelists

Comment 6

5 years ago
(In reply to :aceman from comment #5)
> You can manually remove it from the file virtualFolders.dat in your TB
> profile.
> 
> If this is just a wrong condition in the context menu as comment 3 suggests,
> I can try this.

also missing from file menu
Flags: needinfo?(acelists)
(Assignee)

Comment 7

5 years ago
This is probably caused by the fact that we apparently allow search folders in a news account by mistake. Some code allows them there, but other parts are not prepared for that and don't offer the related actions.
(Assignee)

Comment 8

5 years ago
Created attachment 8362716 [details] [diff] [review]
patch

OK, let's try this. I don't know why the logic for the context menu and the File menu is so different. So I had to change it at several places.

Hopefully it does not open a can of worms. But we need a delete command until we properly prevent creating of Saved search under news or reimplement saved searches to be on a level above the actual accounts (as discussed in other bugs).
Attachment #8362716 - Flags: review?(mkmelin+mozilla)
Attachment #8362716 - Flags: review?(Pidgeot18)
Flags: needinfo?(acelists)

Comment 9

4 years ago
Comment on attachment 8362716 [details] [diff] [review]
patch

Review of attachment 8362716 [details] [diff] [review]:
-----------------------------------------------------------------

The menus still talk about unsubscribe. Could you fix that too?

::: mail/base/content/mail3PaneWindowCommands.js
@@ +286,1 @@
>              return CanDeleteFolder(folder);

drop the else
Attachment #8362716 - Flags: review?(mkmelin+mozilla)
Attachment #8362716 - Flags: review?(Pidgeot18) → review+
(Assignee)

Comment 10

4 years ago
It looks like bug 878805 finally prevented creating search folders under news. So this patch just complements it and allows the user to clean up any existing ones.
(Assignee)

Comment 11

4 years ago
Created attachment 8368202 [details] [diff] [review]
patch v2

This removes the Unsubscribe item when over a search folder. Fixes also the "Newsgroup properties" item in Edit menu.
Attachment #8362716 - Attachment is obsolete: true
Attachment #8368202 - Flags: review?(mkmelin+mozilla)

Comment 12

4 years ago
Comment on attachment 8368202 [details] [diff] [review]
patch v2

Review of attachment 8368202 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. r=mkmelin
I do get an error to console when selecting such a folder, but it doesn't appear to be related to this

::: mail/base/content/mail3PaneWindowCommands.js
@@ +285,2 @@
>              return CanDeleteFolder(folder);
> +          }

no return in else, just fall through an return
Attachment #8368202 - Flags: review?(mkmelin+mozilla) → review+
(Assignee)

Comment 13

4 years ago
Created attachment 8369569 [details] [diff] [review]
patch final

Thanks.
Attachment #8368202 - Attachment is obsolete: true
Attachment #8369569 - Flags: review+
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED
Keywords: checkin-needed
https://hg.mozilla.org/comm-central/rev/04b872817043
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 30.0
You need to log in before you can comment on or make changes to this bug.