Lost images on forward, reply, send ( multipart/related[ multipart/alternative[ text/plain+text/html ] + image/jpeg ] )

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
8 years ago
3 years ago

People

(Reporter: johncoombes48, Unassigned)

Tracking

(Blocks: 1 bug, {testcase})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme?])

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)
Build Identifier: 2.0.0.24 (20100228)

1. I can receive mails with images etc OK.
2. However, when i reply or forward received mails, OR i send a new mail, all embedded images etc "disappear" into thin air.

How can i fix this?
PS I am not exactly a techno-smart guy.

Reproducible: Always

Steps to Reproduce:
1. Send a new mail with embedded images
2. Forward, or reply to a mail with embedded images
3. In each case the images are removed from the message.
Actual Results:  
Nothing. The images eveporate.

Expected Results:  
It should have retained the images just like Outlook does.
Aren't the images attached ? can you go into you sent folder and save one of those faulty emails, come back on this page and attach it using the add attachment link above ?
(Reporter)

Comment 2

8 years ago
Created attachment 440364 [details]
1 attachment showing the incoming mail.

Thanks for getting back to me. The link above is for the incoming mail, which is in Afrikaans (our second national language). I shall try to attach the second file being the sent file (forwarded). You'll see that the image has disappeared and the font completely changed with all kinds of strange characters embedded.
(Reporter)

Comment 3

8 years ago
Created attachment 440365 [details]
The forwarded file

Here's the sent (forwarded) mail file
Attachment #440364 - Attachment mime type: message/rfc822 → text/plain
Attachment #440365 - Attachment mime type: message/rfc822 → text/plain
Blocks: 505172
Component: General → Mail Window Front End
QA Contact: general → front-end
image/jpeg is properly pointed by <img sec="cid:..."> by text/html in multipart/related.
> ------_=_NextPart_001_01CADFC4.3D3E8A51
> Content-Type: image/jpeg;
> 	name="2B8339901.jpg"
> Content-Transfer-Encoding: base64
> Content-ID: <E6B233DCE5CB4258AA74CB0CC351D2A7@notebook>
> Content-Description: 2B8339901.jpg
> Content-Location: 2B8339901.jpg
(<img> tag in decoded text/html part)
> <IMG id=_x0000_i1025 height=224 
>            src="cid:E6B233DCE5CB4258AA74CB0CC351D2A7@notebook" 
>            width=422>

Mail structure.
  multipart/related
    multipart/alternative
      text/plain
      text/html, <IMG src="cid:E6B233DCE5CB4258AA74CB0CC351D2A7@notebook">  
    image/jpeg,   Content-ID: <E6B233DCE5CB4258AA74CB0CC351D2A7@notebook>

Forwarded mail.
> Content-Type: text/plain; charset=UTF-8; format=flowed

As "forward in inline by text/plain mail", text/plain part in multipart/alternative part in multipart/related mail is used as mail body to be forwarded in inline. text/html part in multipart/alternative part in multipart/related mail is ignored.
So, mail structure used upon "forward in inline by text/plain mail" is equivallent to as follows.
  multipart/related
    text/plain
    image/jpeg, Content-ID: <E6B233DCE5CB4258AA74CB0CC351D2A7@notebook>
As image/jpeg part is a part in multipart/related, and as no one uses it, the image/jpeg part in multipart/related is also ignored.
i.e. Set of (text/html + text/image in multipart/related) is ignored.

Reoprter, is image/jpeg part not sent by Tb even when forward in inline with text/html mail?
If image/jpeg part in multipart/related is properly sent, this bug is INVALID.

> Expected Results:  
> It should have retained the images just like Outlook does.

Outlook doesn't look to distingush multipart/related and multipart/mixed, even though RFC for MHTML(multipart/related and cid:) was developed by MS. Outlook probably treats multipart/related as multipart/mixed, and, probably searches Content-Id in multipart/mixed(originally multipart/related mail) upon text/html part rendering. Because of same treatment as multipart/mixed, image/jpeg part is probably treated as attachment part of multipart/mixed mail upon inline forwarding by Outlook, and Outlook probably always sends attachment part upon inline forwarding.
(Reporter)

Comment 5

8 years ago
I ad still waiting to find our whether or not the Mozilla people have a fix for this bug. It is very frustrating having to continually switch over to Outlook to send jpg etc images.
(In reply to comment #5)

Are you talking about mail you attached to this bug? (HTML mail with embed image by <img src="cid:...">)
Or you are talking about multipart/mixed mail with image data attachments or file attachments such as PDF?

If former, why no answer from you, bug opner, to my question in comment #4 before comment of "It is very frustrating..."?

If latter, it may be a result of design change in forward. AFAIR, there is hidden option to force attaching of attachments upon forward. Please search already opened bugs around forward well via "Advanced Search" by yourself. Here is B.M.O. Not support forum.
Summary: Lost images on forward, reply, send → Lost images on forward, reply, send ( multipart/related[ multipart/alternative[ text/plain+text/html ] + image/jpeg ] )
(Reporter)

Comment 7

8 years ago
Good day WADA
Please consider that i am not a technician, merely an old pensioner with a little bit of expertise.
I have read through your comment in 4 & 6. I have no idea what multipart/related etc etc means.
All i can say is that the version of Tb i have installed on my PC receives images fine, but it will neither forward nor send (new mail) any images. For that i have to open Outlook and then cut-and-paste the images from the TB mail and then i am able to send.
ALL images are dropped.
Please help me with this. As i said i have no technical knowledge, so i need a very simple explanation.
Thank you for your work on this so far.
Wada is talking about how the mail is formated internaly , if you use View message source, you'll see the mulipart sections. This is dues to the fact that back in the 80 when email was invented it only understood 7bit ascii (which limits the the char set to 128 characters), later things where added to be able to excahnge images and accents. There are bugs in both TB and outlook with regards to these extensions.

Wada want's to know if you set forward inline in your options and default email format set to html if the forwarded email is ok can you try to do that ?
(Reporter)

Comment 9

8 years ago
Good day Ludovic

I have clicked on Tools/Options/Composition/General and the "Forward
messages box is set for "Inline".

In the Tools/Account Settings/ Composition and Addressing tab the
"Compose messages in HTML format" box is ticked. I assume that makes the
default email format html as you mention.

Thanks for your help.
And you still have the problem ?
See Also: → bug 558128
(Reporter)

Comment 11

8 years ago
Hi Ludovic

Indeed. Since the day i installed Thunderbird i have been unable to use any graphics (jpegs etc) in the mail. Even trying to copy the content from Thunderbird in an attempt to use MS Outlook doesn't work. While i can see the graphics in incoming mail i can do nothing with it after that.

Thanks for continuing support.
john
(Reporter)

Comment 12

8 years ago
Hi there bugzilla people.
My frustration is increasing apace. I am receiving mail from certain correspondents that contain a type of graphics that Thunderbird simply cannot interpret. So i cannot read the entire mailshot.
Is there no solution to the problem?
I mean, surely i cannot be the only user that has this problem? Or if i am, is there something wrong with the software installation?

Help guys, else i have to go out and spend a whole lot of unnecessary money on the new version of Outlook.

The problem, as i see it as a relatively new freeware user, is that without having paid for something there is no accountability on the product provider for proper performance. There is no underlying contract.

This whole thing is starting to suck badly.
Thanks
(Reporter)

Comment 13

8 years ago
One more thing.

The only way i am able to communicate outwards with any mail containing graphics is to paste it into MSWord and attach the doc before sending. That is a whole lot of additional, unnecessary work.

Cheers

Comment 14

8 years ago
Following comments elsewhere I noticed that the Image location for a particular image was:

mailbox:///C%7C/Users/allanb/AppData/Roaming/Thunderbird/Profiles/...

When I changed it to:

mailbox:///C:/Users/allanb/AppData/Roaming/Thunderbird/Profiles/...

the picture showed and sent ok.

To clarify mailbox:///C%7C had to be changed to mailbox:///C:

Hope this helps someone fix the coding.
(Reporter)

Comment 15

8 years ago
Hi Allan
Thanks for your comments. However it sort of sums up everything: ordinary non-tech users like me are really lost in the cosmos here. Mozilla's products are geared towards techies and not lay users.
I reported this major bug 5 months ago and nobody has fixed it yet. There is no "centre" of accountability in the Mozilla world.
So i discovered Windows Mail in my program list and have abandoned Thunderbird. I have also reverted to Internet Explorer.
So Microsoft wins the war and the revolutionaries lose a supporter.

If you take on the giants, make sure that your sling is loaded.

Cheers to the Mozilla gang.
John this might have been fixed by bug 351224. Could you take a few
minutes and download the latest nightly (
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-central/
), backup your profile and test and let us know if this is fixed or not ?
(Reporter)

Comment 17

8 years ago
Hi Ludovic

Before i make a big mistake, please can you provide me with a bit more detail about how to back up "my profile"? I do not find such an option in Thunderbird, so do ia ssume you mean some kind of Windows option? Pardon my igmorance, but my technical skills are somewhat limited.
Regards

Comment 18

8 years ago
I have just downloaded and tried the above nightly and am happy to report that graphics being forwarded seem to have no problem at all. They are referenced properly as per my above post and show correctly in the outgoing forwarded email. 

Note: this issue only seems to effect images that are referenced to the user's machine. Images that have a web address location seem to work fine.

John: get MozBackup to back up your profile. iIt will also auto restore if you choose that function. It is quite self explanatory and easy to use.
(In reply to comment #17)
> Hi Ludovic
> 
> Before i make a big mistake, please can you provide me with a bit more detail
> about how to back up "my profile"? I do not find such an option in 

http://mozbackup.jasnapaka.com/ is the place to get mozbackup from. More indeepth documentation can be found at http://kb.mozillazine.org/Thunderbird_:_FAQs_:_Backing_Up_and_Restoring.
(Reporter)

Comment 20

8 years ago
Hi Ludovic and Allan

Dumbo here again. I clicked on the URL provided by Ludovic a couple of comments above and that takes me to a page with a list of downlaods. There is no indication which one i am supposed to download. Can you guys give me a "bulls' eye" pointer?

Thanks
(Reporter)

Comment 22

8 years ago
Hi Ludovic

I downloaded Shredder and then attempted to send a mail with a picture in the body to one of my other mail addresses.

The pic is dropped and neither the sent file nor the received file contain the picture.

John

OK Before i sign off this response. I was able to forward a mail with an attached picture (jpeg) and this worked alright.

I used Windows mail to insert the photo into the mail and i attached the same file to the mail. The Windows sent mail file reflects both pictures (included and attached). However, Shredder only shows the attached file. In other words embedded graphics are discarded on the receive / forward.

As a note of comparison between Shredder and Windows Mail. WM has an "Insert" button to insert the photo into the body of the mail. With Shredder i can attach OK, but if if i drag and drop the photo into the mail it shows the photo, but as soon as i hit the send button, the graphics disappear out of the mail.

Other suggestions?

Thanks
 (In reply to comment #22)
> Other suggestions?

None for now.

Comment 24

8 years ago
Hi
You have said to use 
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-central/
I use Seamonkey for my mail and have the same problem. Do you have a fix for that also please?
Thanks
John Coombes (reporter) do you still see this bug on recent version of TB?
Can you try forwarding testcase.eml of attachment 40364 [details] [diff] [review] to test?

Worksforme: testcase of attachment 40364 [details] [diff] [review] wfm when forwarded on TB12.0.1 / WinXP.

Similar bugs (confirmed):
Bug 501298, Bug 754655, Bug 671440
Keywords: testcase

Comment 26

3 years ago
Hi John

We have just had the same problem. I can't say whether this is a bug or there is some hidden setting, but what I can say is that there is a simple workaround. Right click on the message and select "Edit as new message". Then change the To: details as appropriate (and possibly prepend the subject with "Fwd: ") and send it, and your images should be sent OK. Hope that helps; please let us know if it does.

Brian

Updated

3 years ago
Component: Mail Window Front End → Message Compose Window
Whiteboard: [dupeme?]

Comment 27

3 years ago
Hi guys,
maybe I have a solution that some of you will help.
In my case the guilty was ENIGMAIL programm.
In its settings > advanced I had a few options checked.
UNCHECK all formatting options and maybe (like me) you will be OK then.
Now when I reply/forward any message I can see images and no problem with sending :)

If you do not use Enigmail - maybe check your other plugins - just turn off one by one. And then try to turn off any formatting options...

Good luck!
Domin

Comment 28

3 years ago
I can reply to and forward the message from attachment 440364 [details]. Let's close this ancient bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.