"Find as you type" takes focus away when the partial search is found

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: Steve Magruder, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2011-1-30])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 GTB7.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 GTB7.0

When using the Find (Ctrl+F) feature, as I type, it locates text based on characters I enter into the Find input field, but even though I haven't completed typing in what I'm searching for, focus switches away from the input field.  I have to keep clicking the input field to finish typing what I'm looking for.

Reproducible: Always

Steps to Reproduce:
1.Go to a web page.
2.Ctrl+F
3.Start typing what you're looking for.
4.Once a partial match is found, focus switches to the found location, even though you may still be typing what you're trying to find.
Actual Results:  
(Should be clear from the Steps)

Expected Results:  
Focus should have stayed on the Find input field so I could finish typing what I was trying to find in the page's content.
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles

You can also try to reproduce in Firefox 4 Beta 8 or later, there are many improvements in the new version, http://www.mozilla.com/en-US/firefox/all-beta.html
Whiteboard: [CLOSEME 2011-1-30]

Comment 2

8 years ago
not the poster, but I had this problem, which is now resolved for me.
(Reporter)

Comment 3

8 years ago
Yes, this problem was either directly or inadvertently fixed in a recent Firefox update, but I can't remember which one.  It's working fine as of 3.6.13.

It would be useful if the developers could close this as a duplicate of the problem that was officially fixed.
Since we aren't sure even what update it was that was fixed in, finding the exact bug that fixed this is going to be nearly impossible without lots of testing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

7 years ago
Sadly, this bug has re-emerged in Firefox 4.  Using Firefox 4.0 on Windows 7 Service Pack 1.
(Reporter)

Comment 6

7 years ago
Nevermind: This problem is being caused the Fast Video Download extension v4.0.1.  With it disabled, search works normally again.
You need to log in before you can comment on or make changes to this bug.