Treat 400, 401, 404 responses differently for logins

RESOLVED DUPLICATE of bug 730989

Status

()

RESOLVED DUPLICATE of bug 730989
9 years ago
4 months ago

People

(Reporter: Mardak, Unassigned)

Tracking

unspecified
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Right now we have..

400: server error (* hits the default: case)
401: login rejected
404: login rejected

We could actually identify them differently and expose that to the user:
400: invalid username (probably typed in an @email address)
401: login rejected (wrong password)
404: username doesn't exist (valid username format, but no account here)
Future for now, may re-evaluate later.
Target Milestone: --- → Future
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 730989
(Assignee)

Updated

4 months ago
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.