_DOMElement assertion on livemarks update

RESOLVED FIXED in Firefox 3.7a5

Status

()

Firefox
Bookmarks & History
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: mak, Assigned: mak)

Tracking

({dogfood, regression})

Trunk
Firefox 3.7a5
dogfood, regression
Points:
---
Bug Flags:
in-testsuite -
in-litmus ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
sounds like i get a bunch of assertions when a livemark updates, not sure what's up, investigating.
(Assignee)

Comment 1

8 years ago
i think i figured out this happens when there is no active window, since livemarks update can happen when there is no FX window active, we hit the assertion. I can reproduce this asking a livemark to update and immediately switching to another unrelated window.
I think links between PUIU and window are too lazy, so i'll try to extract the window/document from params.
(Assignee)

Comment 2

8 years ago
Created attachment 440001 [details] [diff] [review]
patch v1.0

This should be good, since these are tasks that could happen in background, it's common we could not have an activeWindow. I just get the document from the popup we are building then, for backwards compat with add-ons i use the top browser window otherwise.
Attachment #440001 - Flags: review?(dietrich)

Updated

8 years ago
Flags: in-testsuite-
Flags: in-litmus?
Target Milestone: --- → Firefox 3.7a5
Comment on attachment 440001 [details] [diff] [review]
patch v1.0

r=sdwilsh
Attachment #440001 - Flags: review?(dietrich) → review+

Comment 4

8 years ago
FYI, I won't use the nightlies until this is landed.
Keywords: dogfood
(Assignee)

Comment 5

8 years ago
http://hg.mozilla.org/mozilla-central/rev/2e1b0e131c49
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

8 years ago
to reproduce the bug, right click on a livemark, ask for a reload and immediately switch to another application (not a firefox window), then wait some second.

Comment 7

8 years ago
Does this also cover the message I'm receiving "assert mode must have dom element set"?
(Assignee)

Comment 8

8 years ago
(In reply to comment #7)
> Does this also cover the message I'm receiving "assert mode must have dom
> element set"?

it's about it.
You need to log in before you can comment on or make changes to this bug.