Copying from a "view source" window copyes the result, not the sourse of the page

VERIFIED WORKSFORME

Status

()

Core
Serializers
P3
major
VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Eugene Savitsky, Assigned: Akkana Peck)

Tracking

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
1. Load some page.
2. Click View Source
3. Select some source (block)
4. Now copy it into some txt document for example.

Result: you copyed a rendered page (without elements)

Expected result: you should copy the *source* with all tags etc.

Comment 1

17 years ago
over to XPApps
Assignee: asa → ben
Component: Browser-General → XP Apps: GUI Features
QA Contact: doronr → sairuh
hi eugene, got some questions:

1. what platform did you see this on?
2. how did you copy the selection --ie, by keyboard shortcut (eg, Ctrl+C) or if
you're on a unix platform, by the mere selection action of dragging?
3. what build (trunk or branch?) did you use?

i'm guessing that this should go to DOM->text conversion. but punt back if
otherwise.
Assignee: ben → akkana
Component: XP Apps: GUI Features → DOM to Text Conversion
QA Contact: sairuh → sujay
(Assignee)

Comment 3

17 years ago
Yes, DOM->Text conversion is a good place for this bug.  But I can't reproduce
it; when I copy (by autocopy) from View Source, whether I paste (middle-mouse)
into emacs (plaintext) or our editor (html), I get the source html tags pasted,
complete with html tags.  This is true on yesterday's linux debug trunk build,
and yesterday's optimized linux branch build.

Marking worksforme -- reopen with very specific instructions if you're still
seeing it.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 4

17 years ago
verified in 10/12 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.