[Junk] "Not junk" does not work properly

RESOLVED WORKSFORME

Status

MailNews Core
Filters
RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: BenB, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Config (probably irrelevant, but just mentioning to be sure):
- Junk column is shown
- Message pane is hidden

Reproduction:
1. Open folder A, mark a mail as "Junk" (e.g. press "j")
2. Notice that you made a mistake and do "Undo" (e.g. Ctrl-Z)
3. The mail is still marked "Junk", so mark as "Not Junk" (e.g. Shift-J)
4. Open folder B
5. Open folder A again

Actual result:
After step 3, the msg is not marked as Junk, it has no Junk icon anymore.
After step 5, the msg is marked as Junk, it does have Junk icon again.

Expected result:
After step 2, the message is not marked Junk anymore, and most importantly, the changes to the junk training have been undone.
Definitely after step 5, the msgs is no longer marked Junk.

Related:
Bug 179637

Comment 1

8 years ago
This WFM, so it's not clear what is different about your setup.

I would suggest that you load JunQuilla and look at the junk status + column to see more information about the status of the item that is marked as junk at the different stages.
(Reporter)

Comment 2

8 years ago
OK, some more data:
- IMAP (Cyrus, local server)
- lots of msgs in the folder (bugzilla in this case)

Comment 3

8 years ago
The step 5 item is WFM with v3.1. Ben, do you also see this in v3.1?
your step 3 is your referenced bug 179637 - which is not a bug per se, because there is no "undo junk". 

rkent, regarding undo junk, is there a better path than reopening bug 179637?
(Reporter)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

8 years ago
WFM now.
You need to log in before you can comment on or make changes to this bug.