If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Unable to unsubscribe from/remove/delete feed that has had its backing/containing folder moved

RESOLVED DUPLICATE of bug 571760

Status

MailNews Core
Feed Reader
RESOLVED DUPLICATE of bug 571760
8 years ago
6 years ago

People

(Reporter: tuggyne, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
Similar to bug 530512, but different error in the Console:
Error: uncaught exception: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIRDFDataSource.Unassert]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: chrome://messenger-newsblog/content/utils.js :: deleteFeed :: line 127"  data: no]

STR:
1. Subscribe to a feed (try http://feeds2.feedburner.com/22_words)
  a. If necessary, create an RSS/news account by choosing File -> New -> Other Accounts... and following the wizard to create a Blogs & News Feeds account
  b. Select the RSS/news account in the folder pane
  c. Choose File -> Subscribe...
  d. Click Add
  e. Enter the feed URL and click OK
(a folder will be created with the feed's title in the folder pane)
  f. Close the Feed Subscriptions dialog
2. Move the folder auto-created in step 1 to another location in the RSS/news account (for example, create a new folder by right-clicking the root and choosing New Folder..., then move the folder into it)
3. Unsubscribe from the feed added in step 1, using the Feed Subscriptions dialog
  a. Select the RSS/news account in the folder pane
  b. Choose File -> Subscribe...
  c. Select the feed in the tree view (inside its appropriate folders)
  d. Click Remove and answer Yes to the prompt
  e. Close the Feed Subscriptions dialog

Actual:
The feed is not unsubscribed from, either immediately (as would be expected) nor after restarting. Also, an error appears in the Console.

Expected:
Feed to be unsubscribed.

Note that the workaround in bug 530512 comment #2 isn't really acceptable to me: I do not wish to remove previously downloaded feed items, only stop downloading new ones (in this case, because the feed in question rather suddenly and permanently became a lot less interesting). Also note that *all* of my feeds have been moved to a non-default location within the RSS account, so I am (apparently) unable to unsubscribe from any of them.
Reproduced in Safe Mode, restarting between each step; at least three different feeds exhibit this behavior; Lanikai 3.1b1 with another profile likewise displays this bug.
See Also: → bug 547543

Updated

7 years ago
Duplicate of this bug: 604920

Updated

7 years ago
Duplicate of this bug: 585349

Comment 3

7 years ago
Note that also the feed settings ("Edit" in the "RSS Subscriptions" dialog) are not working properly in such a moved feed folder. You can toggle the "show summary" option and it seems to be stored, but it has no effect on the display. Furthermore, the storage folder is always empty when opening the dialog, even if you selected the correct one before.

Comment 4

6 years ago
the specific error above is fixed in bug 705504.  as for the bad behavior on folder move/renames, this is like bug 571760.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 571760
You need to log in before you can comment on or make changes to this bug.