When thunderbird shortens names of news-folders, it should not create identical "aliases" in the folder list

RESOLVED DUPLICATE of bug 310769

Status

Thunderbird
Folder and Message Lists
RESOLVED DUPLICATE of bug 310769
8 years ago
8 years ago

People

(Reporter: Daniel Andre Eikeland, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.3) Gecko/20100415 Ubuntu/10.04 (lucid) Firefox/3.6.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.9) Gecko/20100415 Thunderbird/3.0.4

When I subscribe to two (or more) different newsgroups that can be "shortened" identically, thunderbird should try to remove fewer letters so they don't appear with the same shortened "alias" in the folder list. Example:

Subscribing to "company.customers.scouts.test" and "company.customers.skiing.test" will all be shortened to "c.c.s.t" in the colder list. This only gets worse when you add "company.cloud.systems.test" to the mix (yes, these are made up names, but used to illustrate the problem).

Thunderbird should try to shorten the name by removing one less letter until it is no longer identical. This way, it would say "c.c.sc.t" and "c.c.sk.t" instead, making the folders easy to distinguish. 

Reproducible: Always

Steps to Reproduce:
1. Subscribe to newsgroups that starts with the same letter in all subgroups
2. Enable the shortened names function in the folder list
3. Watch the newsgroup folders become indistinguishable


Expected Results:  
Thunderbird should shorten the folder names by removing fewer letters (starting from the back) until they are not identical anymore.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 310769
You need to log in before you can comment on or make changes to this bug.