Closed Bug 560510 Opened 10 years ago Closed 6 years ago

deezer.com - search field does not work unless UA string contains "Firefox"

Categories

(Web Compatibility :: Desktop, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: pascalc, Unassigned, NeedInfo)

References

()

Details

(Whiteboard: [country-fr] [notcontactready] )

Attachments

(2 files)

1/ Go to http://www.deezer.com/fr/
2/ create an account
3/ click on the "Music" (or Musique if your locale is set to French) tab at the top
4/ in the upper right of the page there is a search field for artists/title, type any request
5/ either click on one of the proposals in the ajax-powered drop down menus or click on the ok button

expected result:
send request and show results

actual result:
nothing happens,no error in js console when clicking on the button

It works fine with 3.6.3 so it may be a regression on trunk (or a tech evang bug on the site side if they do browser sniffing)

Tested with a new profile with:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a5pre) Gecko/20100420 Minefield/3.7a5pre
that's a Tech Evang bug, changing my UA from Minefield/3.7a5pre to Firefox/3.7a5pre makes it work
Assignee: nobody → french
Component: General → French
Product: Firefox → Tech Evangelism
QA Contact: general → french
Version: Trunk → unspecified
Pascal, can you please contact them and let them know they should be sniffing for "Gecko" rather than "Firefox" if they must sniff for something? Point them here or to this site:

http://geckoisgecko.info
Blocks: geckoisgecko
Summary: search field on deezer.com does not work (works with 3.6) → deezer.com - search field does not work unless UA string contains "Firefox"
I sent them a message through their bug reporting system
bug 588874 fixed that
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
(In reply to comment #4)
> bug 588874 fixed that

Only for Firefox; that's not the only Gecko browser.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
OS: Linux → All
Hardware: x86 → All
Duplicate of this bug: 527798
Is this bug still going on? or make sense?
I can't test it from Japan.
If not valid anymore, close it as INVALID.
Flags: needinfo?(pascalc)
Assignee: french → nobody
Component: French → Desktop
Whiteboard: [country-fr] [notcontactready]
I changed my UA to Iceweasel and it works, marking fixed.
Status: REOPENED → RESOLVED
Closed: 10 years ago6 years ago
Flags: needinfo?(pascalc)
Resolution: --- → FIXED
I'm having very similar trouble with very recent versions of Firefox (46, 47) on www.deezer.com .

After logging in and clicking on one of the sections like "Hear This", "New Releases" or "Mixes" does not load the corresponding page. Hitting reload does show the page, but it's sporadic.

The main problem is that the search field does not work. Suggestions are not triggered and no search is executed. On reloading the page, sporadically a notification appears saying "Flash Player is not installed on your computer". When that happens, and I click away the notification, suddenly everything works fine. The different sections of the page are displayed, the search works as intended.
I'm having very similar trouble with very recent versions of Firefox (46, 47) on www.deezer.com .

After logging in and clicking on one of the sections like "Hear This", "New Releases" or "Mixes" does not load the corresponding page. Hitting reload does show the page, but it's sporadic.

The main problem is that the search field does not work. Suggestions are not triggered and no search is executed. On reloading the page, sporadically a notification appears saying "Flash Player is not installed on your computer". When that happens, and I click away the notification, suddenly everything works fine. The different sections of the page are displayed, the search works as intended.
Hi JD, to clarify -- do you have Flash installed (and enabled) on your computer?
Flags: needinfo?(vabanque)
Hello Mike,

yes, Flash is installed and enabled. And once I can get to a certain artist's page, the player works fine.

But for some reason it's only when the error message appears the search on the site works correctly. I'll attach screenshots to demonstrate.
I just realized the issue has nothing to do with flash or Firefox; it's the HTTPS connections forced by the "HTTPS Everywhere" add-on that cause the strange behaviour (not sure why the behaviour is so inconsistent). Everything works normally if I disable the add-on and the issue reappears when I enable it.
Ah, glad you figured that out. Can you report your issue to HTTPS Everywhere here: https://github.com/EFForg/https-everywhere/issues/ ?
(or comment with additional details on this one: https://github.com/EFForg/https-everywhere/issues/4768)
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.