Firefox doesn't redirect to access denied page using Explicit Web Proxy

RESOLVED DUPLICATE of bug 492558

Status

()

RESOLVED DUPLICATE of bug 492558
8 years ago
8 years ago

People

(Reporter: edans.sandes, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.9.2) Gecko/20100115 Firefox/3.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.9.2) Gecko/20100115 Firefox/3.6

When I access https://www.proxy.org, my WebProxy refuses the connection and sends an access denied page to my Firefox 3.6.3. Though, Firefox doesn't redirects, but shows the following message: "Unable to connect   Firefox can't establish a connection to the server at www.proxy.org.". 

Firefox 2.0.0.20 and Internet Explorer redirects the request to the proper access denied page.

Below is the captured stream of the connection using Firefox 3.6.3. The same response is sent to Firefox 2.0.0.20 and IE. The issue happens only with https. No problem with http.

CONNECT www.proxy.org:443 HTTP/1.1
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Proxy-Connection: keep-alive
Host: www.proxy.org

HTTP/1.1 502 Bad Gateway
Content-Type: text/html
Content-Length: 457
Connection: keep-alive
Keep-Alive: timeout=60, max=8

<html><head><meta http-equiv='refresh' content='0;url=http://...host.../.../access_denied?...&URL=https://www.proxy.org/'></head></html>

Reproducible: Always

Steps to Reproduce:
1. Configure explicit proxy to all protocols (ex.: my_host:3128).
2. Replay from the proxy the response below. You can use netcat (nc -i1 -l 3128 < response.txt) to reproduce the same response.

HTTP/1.1 502 Bad Gateway
Content-Type: text/html
Content-Length: 457
Connection: keep-alive
Keep-Alive: timeout=60, max=8

<html><head><meta http-equiv='refresh' content='0;url=http://...host.../.../access_denied?...&URL=https://www.proxy.org/'></head></html>

3. Access any https page.

Actual Results:  
Firefox 3.6.3 shows:
---------
Unable to connect
Firefox can't establish a connection to the server at www.proxy.org.
---------

Firefox-2.0.0.20 and IE 7 redirects to the proper access_denied page.

Expected Results:  
Redirection to the access_denied page.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 492558
You need to log in before you can comment on or make changes to this bug.