"ASSERTION: How can the mouse be over a window but not over a view in that window?"

RESOLVED FIXED in mozilla8

Status

()

Core
Widget: Cocoa
RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

({assertion})

Trunk
mozilla8
x86
Mac OS X
assertion
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Sometimes, moving the mouse out of the window (through the bottom of the window) triggers this assertion.  I haven't found reliable steps, but I can usually hit it within a minute of fiddling.  It seems to be easier to hit while loading a page.

###!!! ASSERTION: How can the mouse be over a window but not over a view in that window?: 'view', file /Users/jruderman/central/widget/src/cocoa/nsChildView.mm, line 6103

(gdb) bt
#0  0x95efae42 in __kill ()
#1  0x95efae34 in kill$UNIX2003 ()
#2  0x95f6d23a in raise ()
#3  0x0491f9e8 in RealBreak () at /Users/jruderman/central/xpcom/base/nsDebugImpl.cpp:417
#4  0x0491f9f5 in Break (aMsg=0xbfffdfcc "###!!! ASSERTION: How can the mouse be over a window but not over a view in that window?: 'view', file /Users/jruderman/central/widget/src/cocoa/nsChildView.mm, line 6103") at /Users/jruderman/central/xpcom/base/nsDebugImpl.cpp:517
#5  0x0492004e in NS_DebugBreak_P (aSeverity=1, aStr=0x4ca78e8 "How can the mouse be over a window but not over a view in that window?", aExpr=0x4c292d4 "view", aFile=0x4ca74f4 "/Users/jruderman/central/widget/src/cocoa/nsChildView.mm", aLine=6103) at /Users/jruderman/central/xpcom/base/nsDebugImpl.cpp:361
#6  0x04714e38 in ChildViewMouseTracker::ViewForEvent (aEvent=0x1c040ec0) at /Users/jruderman/central/widget/src/cocoa/nsChildView.mm:6103
#7  0x04714eba in ChildViewMouseTracker::ReEvaluateMouseEnterState (aEvent=0x1c040ec0) at /Users/jruderman/central/widget/src/cocoa/nsChildView.mm:6073
#8  0x04714fe8 in ChildViewMouseTracker::MouseMoved (aEvent=0x1c040ec0) at /Users/jruderman/central/widget/src/cocoa/nsChildView.mm:6090
#9  0x04715025 in -[ChildView mouseMoved:] (self=0x1b53b6c0, _cmd=0x90688684, aEvent=0x1c040ec0) at /Users/jruderman/central/widget/src/cocoa/nsChildView.mm:3203
#10 0x961c0731 in -[NSWindow sendEvent:] ()
#11 0x04706145 in -[ToolbarWindow sendEvent:] (self=0x1684c80, _cmd=0x9066e4b8, anEvent=0x1c040ec0) at /Users/jruderman/central/widget/src/cocoa/nsCocoaWindow.mm:2237
#12 0x9618cd91 in -[NSApplication sendEvent:] ()
#13 0x960e9fe7 in -[NSApplication run] ()
#14 0x04701233 in nsAppShell::Run (this=0x13d3230) at /Users/jruderman/central/widget/src/cocoa/nsAppShell.mm:747
#15 0x0446b6c0 in nsAppStartup::Run (this=0x1609290) at /Users/jruderman/central/toolkit/components/startup/src/nsAppStartup.cpp:182
#16 0x035b7e05 in XRE_main (argc=1, argv=0xbfffef10, aAppData=0xa0eae0) at /Users/jruderman/central/toolkit/xre/nsAppRunner.cpp:3521
#17 0x00002826 in main (argc=1, argv=0xbfffef10) at /Users/jruderman/central/browser/app/nsBrowserApp.cpp:158
Is this on 10.5 or on 10.6?
(Reporter)

Comment 2

7 years ago
10.5

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a5pre) Gecko/20100418 Firefox/3.7a5pre
Depends on: 675208
Bug 675208 removed the assertion.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla8

Updated

4 years ago
Duplicate of this bug: 571334
You need to log in before you can comment on or make changes to this bug.