Closed Bug 560813 Opened 12 years ago Closed 9 years ago

crash on mysqladmin [@ nsDisplayTextDecoration::Paint(nsDisplayListBuilder*, nsIRenderingContext*) ] and [@ nsTextFrame::Reflow(nsPresContext*, nsHTMLReflowMetrics&, nsHTMLReflowState const&, unsigned int&) ] also [@ ComputeLineHeight ]

Categories

(Core :: Layout, defect)

x86
macOS
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: web, Unassigned)

References

Details

(Keywords: crash)

Crash Data

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; de; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; de; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3

Since version 3.6 firefox crashes on mysqladmin

Reproducible: Always
Whiteboard: [needs more info from the reporter] [closeme 2010-05-25]
Would you provide a crash report ID by typing about:crashes in the address bar and copying and pasting any crash id links to this bug.
Seems similar to bug 554544 (same signature, OS). You get this regularly, right?
Depends on: 554544
Maybe similar? However, everytime I try to use phpMyAdmin or want to edit a wikipedia-article it crases :-(
Yes, that bug is identified as a major problem and there's a fix, however since the developers don't have the problem, it wasn't verified that it fixes the crash.

There isn't a 3.6 build with that fix available for testing, yet.

---
for the reference:
First three crash ids are [@ nsDisplayTextDecoration::Paint(nsDisplayListBuilder*, nsIRenderingContext*) ] and [@ nsTextFrame::Reflow(nsPresContext*, nsHTMLReflowMetrics&, nsHTMLReflowState const&, unsigned int&) ]

These are [@ ComputeLineHeight ]:
http://crash-stats.mozilla.com/report/index/bp-62277195-4c34-44eb-9a9a-2e5442100422
http://crash-stats.mozilla.com/report/index/bp-2e3a840c-9c3d-47f1-ba3b-77f2f2100422

The last three are archived.
Keywords: crash
Summary: Since version 3.6 firefox crashes on mysqladmin → crash on mysqladmin [@ nsDisplayTextDecoration::Paint(nsDisplayListBuilder*, nsIRenderingContext*) ] and [@ nsTextFrame::Reflow(nsPresContext*, nsHTMLReflowMetrics&, nsHTMLReflowState const&, unsigned int&) ] also [@ ComputeLineHeight ]
Whiteboard: [needs more info from the reporter] [closeme 2010-05-25]
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
nsDisplayTextDecoration::Paint(nsDisplayListBuilder*, nsIRenderingContext*)
bp-908101b1-afd4-4a6d-a30b-153232110514
EXCEPTION_ACCESS_VIOLATION_READ
0xffffffffffffffff
0	xul.dll	nsDisplayTextDecoration::Paint	layout/generic/nsHTMLContainerFrame.cpp:150
1	xul.dll	mozilla::layers::ThebesLayerD3D9::DrawRegion	gfx/layers/d3d9/ThebesLayerD3D9.cpp:491
2	xul.dll	mozilla::layers::ThebesLayerD3D9::RenderThebesLayer	gfx/layers/d3d9/ThebesLayerD3D9.cpp:246
3	xul.dll	mozilla::layers::ContainerLayerD3D9::RenderLayer	gfx/layers/d3d9/ContainerLayerD3D9.cpp:328
4	xul.dll	mozilla::layers::ContainerLayerD3D9::RenderLayer	gfx/layers/d3d9/ContainerLayerD3D9.cpp:330
5	xul.dll	mozilla::layers::LayerManagerD3D9::Render	gfx/layers/d3d9/LayerManagerD3D9.cpp:303
6	xul.dll	mozilla::layers::LayerManagerD3D9::EndTransaction	gfx/layers/d3d9/LayerManagerD3D9.cpp:190
7	xul.dll	nsDisplayList::PaintForFrame	layout/base/nsDisplayList.cpp:541
Crash Signature: [@ nsDisplayTextDecoration::Paint(nsDisplayListBuilder*, nsIRenderingContext*) ] [@ nsTextFrame::Reflow(nsPresContext*, nsHTMLReflowMetrics&, nsHTMLReflowState const&, unsigned int&) ] [@ ComputeLineHeight ]
Sascha, do you still see this crash?

xref Bug 549451
Crash Signature: [@ nsDisplayTextDecoration::Paint(nsDisplayListBuilder*, nsIRenderingContext*) ] [@ nsTextFrame::Reflow(nsPresContext*, nsHTMLReflowMetrics&, nsHTMLReflowState const&, unsigned int&) ] [@ ComputeLineHeight ] → [@ nsDisplayTextDecoration::Paint(nsDisplayListBuilder*, nsIRenderingContext*) ] [@ nsTextFrame::Reflow(nsPresContext*, nsHTMLReflowMetrics&, nsHTMLReflowState const&, unsigned int&) ] [@ ComputeLineHeight ]
(In reply to Wayne Mery (:wsmwk) from comment #8)
> Sascha, do you still see this crash?
> 
> xref Bug 549451

Sorry, I don´t use phpMyAdmin anymore. I prefer Sequel Pro on my OS-X
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.