PRIVATE_TO_JSVAL(NULL) yields warning: NULL used in arithmetic with gcc 4.2.1

RESOLVED FIXED

Status

()

Core
JavaScript Engine
--
minor
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: timeless, Assigned: timeless)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed-in-tracemonkey)

Attachments

(1 attachment)

767 bytes, patch
jorendorff
: review+
Details | Diff | Splinter Review
(Assignee)

Description

8 years ago
i686-apple-darwin10-g++-4.2.1 (GCC) 4.2.1 (Apple Inc. build 5646) (dot 1)

In function ‘JSObject* js::ctypes::Library::Create(JSContext*, jsval)’:
js/src/ctypes/Library.cpp:91: warning: NULL used in arithmetic
In function ‘JSBool js::ctypes::Library::Close(JSContext*, uintN, jsval*)’:
js/src/ctypes/Library.cpp:197: warning: NULL used in arithmetic
(Assignee)

Comment 1

8 years ago
Created attachment 440467 [details] [diff] [review]
patch
Assignee: general → timeless
Status: NEW → ASSIGNED
Attachment #440467 - Flags: review?(jorendorff)
Comment on attachment 440467 [details] [diff] [review]
patch

p still needs to be parenthesized. I'll fix it before pushing.

I'll push this with my next batch of stuff (trees are METERED today, so look for it Monday).
Attachment #440467 - Flags: review?(jorendorff) → review+
http://hg.mozilla.org/tracemonkey/rev/450522cbb138
Whiteboard: fixed-in-tracemonkey

Comment 4

8 years ago
http://hg.mozilla.org/mozilla-central/rev/450522cbb138
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Updated

8 years ago
Duplicate of this bug: 562502
You need to log in before you can comment on or make changes to this bug.