If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

entities are getting mangled in editor

VERIFIED FIXED

Status

()

Core
Editor
P3
normal
VERIFIED FIXED
17 years ago
16 years ago

People

(Reporter: Kathleen Brade, Assigned: jst)

Tracking

({dataloss, regression})

Trunk
dataloss, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
In my NS6 branch build from this morning (on Mac), I noticed that various 
entities seem to be getting mangled on output.  HTML tags are ok but things like:  
  &lt; (<)  
  &gt; (>)
  <!-- 
  -->
  &amp; (&)
I'll try to come up with a minimal case for this bug (maybe a duplicate/known 
issue?)

Maybe this is munching only on things in <script> tags?
(Reporter)

Comment 1

17 years ago
It appears to be a problem within script tags.  The file is corrupted when the
user saves or goes into View | HTML Source mode.  I'll attach a small html file
which can be used to see this bug.
Keywords: 4xp, dataloss, regression, rtm
OS: Mac System 8.5 → All
Hardware: Macintosh → All
Target Milestone: --- → M19
(Reporter)

Comment 2

17 years ago
Created attachment 16765 [details]
file that can exhibit entity conversion bug

Comment 3

17 years ago
-> brade
Assignee: beppe → brade
(Assignee)

Comment 4

17 years ago
I have a fix for this in my tree. Kathy, I hope you don't mind me taking this
bug :-).
Assignee: brade → jst
(Assignee)

Comment 5

17 years ago
This is now fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

17 years ago
verified on my Mac debug build
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.