"Copy" doens't copy text inside the "<" and ">"

VERIFIED FIXED

Status

SeaMonkey
General
P3
normal
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: Alex Bischoff, Assigned: asa)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; m18) Gecko/20001010
BuildID:    2000101020

Copy (such as Ctrl-C) doesn't copy text within greater thans, such as an email
address.

Reproducible: Always
Steps to Reproduce:
1. Go to the url above
(http://www.deja.com/%5BST_rn=ps%5D/getdoc.xp?AN=668427465&fmt=text).
2. Try to copy the fellow's email address, starting at "Jeffery" and ending at
the last character in that line.
3. Paste into another app. You'll see that the email address isn't pasted.

Actual Results:  Only the name, and not the characters within "<" and ">" are
copied (nor the "<>" characters themselves).

Expected Results:  It should have copied all selected text to the clipboard.

Comment 1

17 years ago
worksforme 2000101104 win98. Anyone seeing this?

Comment 2

17 years ago
This sounds like a duplicate bug but I can't find it... maybe Akkana knows where 
it is?

Comment 3

17 years ago
No, I haven't seen this one (there were problems previously copying entities
like <, but not stuff inside <>).  Trunk or branch?  Cc'ing noxif people.

Comment 4

17 years ago
Bug was confirmed for me on build 2000101020 but is apprently fixed on 2000101108,
I checked the copy-paste before and after upgrading.
So worksforme on 2000101108 Win32
Fabian.

Comment 5

17 years ago
Ah, then this was probably related to the entity problems, which are now fixed.

Marking fixed, please reopen if this is in error.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 6

17 years ago
*** Bug 56172 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
verified with latest win98 nightly
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.