Creating storage calendar not possible, Lightning hangs using 100% CPU cycles

RESOLVED FIXED in 1.0b2

Status

Calendar
General
--
critical
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Stefan Sitter, Assigned: Fallen)

Tracking

({regression})

Trunk
1.0b2
x86
Windows 7
regression
Bug Flags:
blocking-calendar1.0 +

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Lightning 1.0b2pre (BuildID: 20100421192759) with Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.5pre) Gecko/20100421 Lanikai/3.1b2pre

Steps to reproduce:
1. Create a new Thunderbird profile and install Lightning
2. Select File > New > Calendar
3. In the New Calendar wizard select On My Computer, click Next button

Actual results:
Nothing happens, Lightning hangs with Thunderbird process using 100% CPU cycles. After some while the following dialog is shown:

[[[
Warning: Unresponsive script

A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Script: chrome://calendar/content/calendarCreation.js:229
]]]
Flags: blocking-calendar1.0?
(Reporter)

Comment 1

8 years ago
Regression range: Works in Lightning (2010-04-21-11-27-12)
                  Fails in Lightning (2010-04-21-19-27-59)
                  
Checkins during regression range: https://hg.mozilla.org/comm-central/pushloghtml?startdate=2010-04-21+11:27:12&enddate=2010-04-21+19:27:59 --> caused by checkin for Bug 479867.
Blocks: 479867
(Assignee)

Comment 2

8 years ago
Blocking, obviously.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Flags: blocking-calendar1.0? → blocking-calendar1.0+

Comment 3

8 years ago
I've the same problem with official 1.0b1

using the error console, I get
Erreur : uncaught exception: [Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: chrome://calendar/content/calUtils.js :: getCalendarManager :: line 151"  data: no]

Lighning is then unusable

Comment 4

8 years ago
the test is done under linux.... it's then an OS independent bug
(Reporter)

Comment 5

8 years ago
malet jeanluc: No its not. You are seeing a known issue that happens if you don't install all required system packages before installing Lightning. See Bug 408367 and <http://www.mozilla.org/projects/calendar/lightning/system-requirements.html#linux>.
(Assignee)

Comment 6

8 years ago
Created attachment 441728 [details] [diff] [review]
Fix - v1

This patch takes care, the code affected was added after the cached id patch so I didn't notice.
Attachment #441728 - Flags: review?
(Assignee)

Updated

8 years ago
Attachment #441728 - Flags: review? → review?(ssitter)
(Reporter)

Comment 7

8 years ago
Comment on attachment 441728 [details] [diff] [review]
Fix - v1

r=ssitter
Attachment #441728 - Flags: review?(ssitter) → review+
(Assignee)

Comment 8

8 years ago
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/cd027c7f60a8>
-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0b2
(Assignee)

Comment 9

8 years ago
Pushed to comm-1.9.2 <http://hg.mozilla.org/releases/comm-1.9.2/rev/b0aeae7c7dd0>
-> FIXED
You need to log in before you can comment on or make changes to this bug.