Last Comment Bug 561043 - Message headers with large URLs causes buttons of UI to disappear off right end of screen.
: Message headers with large URLs causes buttons of UI to disappear off right e...
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Message Reader UI (show other bugs)
: unspecified
: x86 Linux
: -- minor with 1 vote (vote)
: Thunderbird 15.0
Assigned To: alta88
:
:
Mentors:
: 696206 724100 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-22 02:58 PDT by plutocrat
Modified: 2012-06-02 11:58 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Screenshot (153.13 KB, image/png)
2010-04-22 02:59 PDT, plutocrat
no flags Details
Screenshot of missing buttons and vertical scroll bar (158.02 KB, image/gif)
2010-11-16 11:51 PST, Robert Oppenheim
no flags Details
Screenshot of missing UI problem in v11. (86.23 KB, image/png)
2012-04-21 17:47 PDT, Robert Oppenheim
no flags Details
patch. (2.37 KB, patch)
2012-04-22 07:41 PDT, alta88
bwinton: review+
Details | Diff | Splinter Review
eml file to reproduce the bug (6.36 KB, application/octet-stream)
2012-05-31 09:26 PDT, wvsrk1lx
no flags Details
Screen shot - window wide - showing all of UI OK. (72.75 KB, image/png)
2012-06-01 02:37 PDT, Robert Oppenheim
no flags Details
Screen shot - window narrow - showing missing UI. (77.44 KB, image/png)
2012-06-01 02:40 PDT, Robert Oppenheim
no flags Details

Description plutocrat 2010-04-22 02:58:44 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.9) Gecko/20100401 Ubuntu/9.10 (karmic) Firefox/3.5.9
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.9) Gecko/20100317 Lightning/1.0b1 Thunderbird/3.0.4

If I have an RSS feed with long URLs, the buttons Delete etc are pushed off the right hand edge of the screen. See screenshot for example. 

Reproducible: Always

Steps to Reproduce:
1. Add a feed with a long URL such as The H - Grand unified feed
Comment 1 plutocrat 2010-04-22 02:59:32 PDT
Created attachment 440724 [details]
Screenshot
Comment 2 Ludovic Hirlimann [:Usul] 2010-04-23 00:09:03 PDT
can you paste a feed url showing up the issue ?
Comment 3 plutocrat 2010-04-23 00:54:41 PDT
Well yes, there's one in the screenshot, and I mention it by name in the bug report. 

Here's the URL then. 

http://rss.feedsportal.com/c/32569/f/491734/index.rss
Comment 4 Ludovic Hirlimann [:Usul] 2010-04-26 04:03:46 PDT
this WFM on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2.5pre) Gecko/20100424 Lanikai/3.1b2pre
Comment 5 John Veness 2010-09-16 10:22:19 PDT
Another feed this happens on is http://www.nintendo.co.uk/NOE/en_GB/xml/news_rss2.xml

(I'm running Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.12) Gecko/20100826 Thunderbird/3.0.7)
Comment 6 Robert Oppenheim 2010-11-16 11:51:50 PST
Created attachment 490939 [details]
Screenshot of missing buttons and vertical scroll bar

I also found UI elements missing - when the FROM line of a message was very long (in my case it is a normal email and not an RSS message). See my screen shot. 

I think the bug requires that the message body be HTML formatted and not plain text. This happens on all such messages, but the UI displays correctly if I export the message to an EML file and then view the EML with TB.

The missing UI elements are located beyond the right side of the window.
(expanding the window shows the missing UI elements).

Missing are message buttons: Forward Archive Junk and Delete, 
and also missing is the vertical scroll bar.

Also there is no horizontal scroll bar (but I think that is another bug).
Comment 7 Robert Oppenheim 2010-11-16 12:00:13 PST
I should note that I am using Windows 7 32-bit and TB 3.1.2.

Also, if I forward the message to myself, then the FROM line changes,
and then the UI displays correctly on the forwarded email.
Comment 8 alta88 2012-04-21 09:53:04 PDT
this is not happening in Tb11, reopen if reproducible in current releases.
Comment 9 Robert Oppenheim 2012-04-21 17:47:11 PDT
Created attachment 617266 [details]
Screenshot of missing UI problem in v11.

I think the problem is much improved - but not gone in TB 11.0.1

In the attached screen shot... 
with the window narrower than the HTML message width,
some of the UI (eg the Delete button) and the scroll bars in the
message body are off screen. For this to happen, a warning must
be present - like "This message may be a scam" with its 
"Ignore Warning" button, or the "Show Remote Content" button.

Making the window wider shows the missing elements (but this
only works if the screen is wide enough to hold the wider window).

[Using TB 11.0.1 and Windows 7.]
Comment 10 alta88 2012-04-22 07:41:39 PDT
Created attachment 617317 [details] [diff] [review]
patch.


you are correct.  identifying an edge case and general excellence in bug reporting warrant a fix.
Comment 11 Jim Porter (:squib) 2012-04-22 13:46:56 PDT
*** Bug 724100 has been marked as a duplicate of this bug. ***
Comment 12 Jim Porter (:squib) 2012-04-22 13:48:06 PDT
*** Bug 696206 has been marked as a duplicate of this bug. ***
Comment 13 Mark Banner (:standard8) 2012-05-24 04:38:21 PDT
Comment on attachment 617317 [details] [diff] [review]
patch.

I think Blake or Mike would be better to look at this.
Comment 14 Blake Winton (:bwinton) (:☕️) 2012-05-31 07:02:10 PDT
Comment on attachment 617317 [details] [diff] [review]
patch.

I can't replicate this behaviour, so I don't think I can review this patch.

Can one of you attach a .eml file that shows the problem, so that I cna continue with it?

(For what it's worth, the code changes seem okay, so once I can verify that this actually fixes the problem, it should get a quick r+.  Oh, another way you could verify it would be to write a test that, say, checks for the horizontal position of an element, and fails if it would be off the screen.  Then I wouldn't need the .eml, and we could be sure we don't break it accidentally in the future.)

Thanks,
Blake.
Comment 15 wvsrk1lx 2012-05-31 09:26:29 PDT
Created attachment 628776 [details]
eml file to reproduce the bug
Comment 16 wvsrk1lx 2012-05-31 09:27:44 PDT
The eml file can be used to more or less reproduce the bug when it's under vertical view.
Comment 17 Blake Winton (:bwinton) (:☕️) 2012-05-31 09:37:38 PDT
Comment on attachment 617317 [details] [diff] [review]
patch.

Awesome, thanks!  I'll review the patch this afternoon with this .eml file.
Comment 18 Blake Winton (:bwinton) (:☕️) 2012-05-31 11:24:20 PDT
Comment on attachment 617317 [details] [diff] [review]
patch.

Sadly, I'm still not seeing it.  (Here's what I do see https://dl.dropbox.com/u/2301433/Screenshots/NoCrop.png if that helps us figure out what I'm doing wrong.)

Thanks,
Blake.
Comment 19 alta88 2012-05-31 12:19:14 PDT
that's what it's supposed to look like with the patch.  without it, the Show Remote Content button is pushed off the screen.  at least on win7.
Comment 20 Blake Winton (:bwinton) (:☕️) 2012-05-31 12:30:02 PDT
Yeah, but I didn't have the patch applied when I took the screenshot…  That's what I saw with just the plain trunk code.
Comment 21 wvsrk1lx 2012-05-31 12:52:05 PDT
Your computer seems to truncate 'always load content from [email address here]' (see attachment 490939 [details]). I just checked the latest Daily build for Mac OS X, and that email address doesn't seem to be truncated. I think the behavior on your computer would be the desired behavior.
Comment 22 Robert Oppenheim 2012-06-01 02:37:01 PDT
Created attachment 629113 [details]
Screen shot - window wide - showing all of UI OK.

This screen shot is with the window wide enough to display all of the UI correctly for the test eml file. I will upload another shot of the same window made narrow enough to show the error of the missing UI elements.
Comment 23 Robert Oppenheim 2012-06-01 02:40:25 PDT
Created attachment 629115 [details]
Screen shot - window narrow - showing missing UI.

Below is a way to reproduce the bug.

Just opening an eml file in TB won't do it for me. TB produces no warning message like "To protect your privacy, Thunderbird has blocked remote content in this message" - and the FROM line is not long enough to easily see the problem.

So here is one way to reproduce the bug....

1) go to www.spamgourmet.com and create an account - which is trivial to do. Just give it a user name and your real email address, and respond to their confirmation email.

[I  guarantee they will not spam you in any way. Its a cool free service that has eaten many thousands of spam emails for me. (See their site for info on how it works).]

2) Download the example "eml file to reproduce the bug" (from tech163) (shortcut: https://bugzilla.mozilla.org/attachment.cgi?id=628776 ) to a temp location on your disk.

3) Open the example eml file in TB (ie double click it in Windows Explorer).

4) Forward the example to your spamgourmet account (which will forward it back to you with a longer FROM line). For best results, use a long spamgourmet 'keyword' to make the FROM line even longer, eg, forward it to something like:
LongTestKeyWord.20.XXXX@spamgourmet.com
(where XXXX is your Spamgourmet user name).

5) Now read the email that Spamgourmet sends back to you.

To see the problem: you must make the TB window small enough, so ...

6) make the window short enough to create a vertical scroll bar in the message,

7) then narrow the window until the scroll bar disappears (bug!).
Also some buttons in the header will get clipped off.

See my new screen shots. One is with the window wide enough to display all of the UI, the other screen shot shows the window narrower so the scroll bar etc is missing.

I am using TB 12.0.1 in Widows 7.

FYI, I looked around to try to learn how I could test this patch, but I am not a TB developer and I found no simple directions for how to try out a patch. Is there a reasonably simple way for me to test it?
Comment 24 Blake Winton (:bwinton) (:☕️) 2012-06-01 05:55:07 PDT
Comment on attachment 617317 [details] [diff] [review]
patch.

Okay, I tried it on my Mac with this morning's code, and I managed to reproduce the bug!  Woo!  So your patch works, and as I'm pretty sure I said previously, the code seems good, so r=me, and thank you for your patience!

>+++ b/mail/base/content/mailWindowOverlay.xul
>@@ -2058,16 +2058,17 @@
>       <label id="allowRemoteContentForAuthorDesc" class="msgNotificaton-smallText text-link"
>+             crop="end"
>              onclick="allowRemoteContentForSender();"/>

The only thing I'ld change here (and I'm not going to insist on it, it's more of a preference) is that you put the onclick on the same line as the crop.

Thanks again,
Blake.
Comment 25 Mike Conley (:mconley) - (needinfo me!) 2012-06-02 11:58:27 PDT
https://hg.mozilla.org/comm-central/rev/7ee39bdf99ae

Note You need to log in before you can comment on or make changes to this bug.