need missing-plugin icon in status bar (because puzzle icon does not show for tiny plugins)

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
P2
normal
RESOLVED WORKSFORME
17 years ago
8 years ago

People

(Reporter: Lynn Webb, Assigned: av (gone))

Tracking

Trunk
mozilla1.4beta
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PL:BRANCH])

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Not sure where the best location for this bug is, but the following sound 
embed tag does not work in Netscape 6: <embed src="/midi/nitemare.mid" 
align="center" border="0" width="51" height="15" autostart="true"  
volume="60" controls="smallconsole">. The console feature no longer works and 
the sound also does not work. It works fine in Netscape 4.x.
(Reporter)

Updated

17 years ago
Keywords: rtm
(Reporter)

Comment 1

17 years ago
The build bug was seen in was 2000-10-10-09-MN6.  

Comment 2

17 years ago
plugins, midi file.
Assignee: asa → av
Component: Browser-General → Plug-ins
QA Contact: doronr → shrir

Comment 3

17 years ago
This is working fine for me on yesterday's windows branck build(20001010). I 
have quicktime 4.1.2 installed. I see this exactly as I see it on 4.72. Sound 
works for me. Attaching a testcase here.

Comment 4

17 years ago
Created attachment 16772 [details]
testcase attached

Comment 5

17 years ago
marking this invalid. 
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 6

17 years ago
Sorry, but still doesn't work for me, even using your test. Should I open the 
bug in Bugscape instead, since it was build 2000-10-10-09-MN6, which is the 
Netscape 6 branch build?
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Reporter)

Comment 7

17 years ago
By the way, I'm using WinNT, and it is not running the Quicktime plugin. I'm
just using the default browser midi plugin. I'm not even given a message that I
need a plugin to hear it.
(Reporter)

Comment 8

17 years ago
I also have Quicktime Player installed on my system.

Comment 9

17 years ago
When you do about:plugins does your midi plugin show up?
(Reporter)

Comment 10

17 years ago
"About:plugins" shows my audio plugin as "audio/x-pn-realaudio-plugin" 
(realplayer). I don't see a place where I can edit plugins except in Helper 
Applications, and when I look there, I only see txt/html. Also, my default 
plugin is "D:\Netscape6US\Netscape 6\plugins\npnul32.dll", with no mime type 
defined.

I tried entering my own plugin info. in the Helper Applications section and got 
the message "helper already exists for audio/midi, do you want to replace it?" 
Said OK. Message popped up again. Said OK. Message popped up AGAIN. Finally had 
to cancel. Midi is still not functioning for me. I performed a typical install, 
not a complete install of this build.
(Reporter)

Comment 11

17 years ago
After closing down the browser because it wouldn't accept my midi plugin change, 
I tried reopening the browser and got the following error message: 
"OleMainThreadWndName: netscp6.exe - Application Error"

"The instruction at "0x00812675" referenced memory at "0x819d80b4". The memory 
could not be "written". Click OK to terminate the application." I already 
reproduced this twice.

Comment 12

17 years ago
that's 50914 you are seeing. It is supposed to be fixed in toda'y s builds. Btw, 
can you try to install crescendo from Liveupdate on you machine and put the dll 
in the plugins folder under ur seamonkey installation and see if that helps? 
Thx.
(Reporter)

Comment 13

17 years ago
I tried out the plugin you suggested. Unfortunately, it didn't play any of the 
sound except the "drums". Also, I had to force the plugin into the Netscape 6 
directory. It wanted to go directly into Communicator's directory. Most 
end-users will not be doing any of this workaround stuff. If Netscape 6 says 
that it is already using an "audi/midi" plugin, but the "about:plugin" says that 
there isn't one installed, there's definitely a problem. The only plugins that 
showed up in my typical install were: npnul32.dll, NPJava130_01.dll, 
NPJava130_01a.dll, NPJava130_01b.dll and NPJava130_01c.dll. Looks like not 
everything that should get installed does get installed.

Comment 14

17 years ago
I think the helper app dialog is looking in the windows registry and sees that 
you have a handler installed on your machine for audio/midi.  It will use that 
if you try to click on a mid file - but that does not mean there is a suitable 
plugin installed for that mimetype (as is confirmed by the output of 
about:plugins).

The issue regarding the installation of the Crescendo plugin is a problem with 
their installer, not with n6 (though users probably won't see it that way).

Comment 15

17 years ago
so what do we do of this bug? <embed> tag does work for me...
(Assignee)

Comment 16

17 years ago
As it is stated in the summary it is definitely invalid. The problem that NS6 
comes with no music plugins is not really plugins issue.
(Reporter)

Comment 17

17 years ago
OK. I'm changing the summary. The bug is that the client doesn't warn the user 
that s/he does not have a plugin for the embedded midi file. 
Summary: Embed music tag does not work in Netscape 6 → NS6 does not warn user of missing midi plugin
(Assignee)

Comment 18

17 years ago
Shrirang, could you please check if the default plugin is launched on the html 
code specified? Probably an issue of size not enough to see the puzzle peace.

Comment 19

17 years ago
Andrei, unless I change the 'height' attribute to 35, the puzzle icon is not 
appearing. I remeber a bug with this problem was logged but it worked with the 
reporter's testcases.  
(Assignee)

Comment 20

17 years ago
Changing summary. The old one read 'NS6 does not warn user of missing midi 
plugin'.

Frankly, I don't know what to do about this. The size could even be specified 
0x0 to make the plugin intentionally invisible. In this case the default plugin 
will not show up at all and will probably be unclickable. Doing pop up in cases 
like this does not seem to be good solution to me.
Summary: NS6 does not warn user of missing midi plugin → Small size in EMBED tag keeps user uninformed about needed plugin
Not RTM stop-ship. rtm-, Future. Not even sure we'll fix this; may ultimately
WONTFIX. If content developers want the default plug-in to show up in the
meantime, they need to make the size large enough that the user will see it.
Whiteboard: [rtm-]
Target Milestone: --- → Future

Comment 22

17 years ago
Lots of overlap with bug 52905.
(Assignee)

Comment 23

17 years ago
The main issue with 52905 was that somehow you couldn't click on the space 
occupied by the default plugin, but it is clickable even if it is cropped to 
'invisibility'.

Comment 24

17 years ago
Methinks `Extra plug-ins are needed to display all of this page' should replace
`Done' as status bar text in this situation. Clicking the status bar should then
let you download the plug-in.

Comment 25

16 years ago
Still can't see the puzzle piece on tiny EMBEDs in version 0.9.6.
I'll test a more recent nightly in a few moments.

Comment 26

16 years ago
The problem still exists in build 2001121309.

Comment 27

16 years ago
I like mpt's solution of adding text to the status bar.

Updated

16 years ago
Whiteboard: [rtm-]

Comment 28

16 years ago
proposed solution is to mimic the current cookie implementation, in that when
the default plug-in is to be displayed, have the plug-in icon render in the
window status bar, the user would then select the icon and be directed to the
appropriate location.

setting to PL2:P2
Severity: normal → critical
Depends on: 83754
Priority: P3 → P2
Whiteboard: [PL2:P2]
Target Milestone: Future → mozilla1.0.3

Updated

16 years ago
Target Milestone: mozilla1.0.3 → mozilla1.1alpha

Comment 29

16 years ago
*** Bug 143424 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

16 years ago
Severity: critical → normal
Summary: Small size in EMBED tag keeps user uninformed about needed plugin → Need to notify user about missing plugin -- regular puzzle piece is not always the option, plugin may be hidden or sized down. Implement small plugin icon in the status bar.

Updated

15 years ago
Target Milestone: mozilla1.1alpha → mozilla1.2beta
(Assignee)

Updated

15 years ago
Target Milestone: mozilla1.2beta → mozilla1.3alpha

Comment 30

15 years ago
will work this issue in the plug-in branch
Whiteboard: [PL2:P2] → [PL:BRANCH]
Target Milestone: mozilla1.3alpha → mozilla1.4beta

Updated

14 years ago
Summary: Need to notify user about missing plugin -- regular puzzle piece is not always the option, plugin may be hidden or sized down. Implement small plugin icon in the status bar. → need missing-plugin icon in status bar

Updated

14 years ago
Summary: need missing-plugin icon in status bar → need missing-plugin icon in status bar (because puzzle icon does not show for tiny plugins)
This works for me with a current Seamonkey 1.9.1 branch build on win2003.
Is this still a valid bug with the new plugin info bar ?
QA Contact: shrir → plugins
marking wfm because we have a new info bar for missing plugins in Seamonkey and in Firefox
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.