Crash in [@ strstr | NPOFFICE.DLL@0x1455 ]

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
--
critical
RESOLVED WORKSFORME
8 years ago
8 months ago

People

(Reporter: Zane U. Ji, Assigned: Zane U. Ji)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(2 attachments)

(Assignee)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100420 SeaMonkey/2.1a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.3a5pre) Gecko/20100420 SeaMonkey/2.1a1pre

http://crash-stats.mozilla.com/report/index/bp-2e1f9f8b-6f91-4202-be1b-646182100422

Reproducible: Always

Steps to Reproduce:
1. Install SeaMonkey V2.0.4 or nightly
2. Install MS Office 2003
3. Create a new profile and start SeaMonkey
5. Open http://office.microsoft.com/en-us/word/HP052567391033.aspx
Actual Results:  
SM crashes.

Expected Results:  
Opens that URL.
(Assignee)

Comment 1

8 years ago
Created attachment 440744 [details]
Debug Information

The problem is caused by an uninitialized variable at
http://hg.mozilla.org/mozilla-central/file/ab4c6ba5ff70/modules/plugin/base/src/nsNPAPIPlugin.cpp#l917

Comment 2

8 years ago
This crash comes from plugins code, apparently.

Plugins devs: Note that SeaMonkey is not doing libxul builds, those are --enable static, so OOPP isn't built.
Component: General → Plug-ins
Product: SeaMonkey → Core
QA Contact: general → plugins
(Assignee)

Comment 3

8 years ago
Yet the stack shows that strstr is called by SM.

Updated

8 years ago
Assignee: nobody → ZaneUJi
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash

Comment 4

8 years ago
Created attachment 440745 [details] [diff] [review]
zane's patch
Attachment #440745 - Flags: review?(jst)

Comment 5

8 years ago
(In reply to comment #3)
> Yet the stack shows that strstr is called by SM.

Sure it's _called_ by SM, but the code we're using there is Mozilla core code, that's why the bug belongs in this component. And as you see, moving here prompted someone to act on it. :)
(Assignee)

Comment 6

8 years ago
Sorry, I didn't get your point.

Comment 7

8 years ago
zane: you filed the bug in product 'seamonkey'. kairo moved the bug to product 'core'. SeaMonkey is roughly speaking a consumer of Core. He was just explaining the move.

kairo: no, I opened the bug as soon as i saw crash and npoffice :). But if it wasn't me, yes, the move here might have triggered something.

Updated

8 years ago
Attachment #440745 - Flags: review?(jst) → review+
Crash Signature: [@ strstr | NPOFFICE.DLL@0x1455 ]
I'm marking this bug as WORKSFORME as bug crashlog signature didn't appear from a long time (over half year).
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.