Closed Bug 561097 Opened 10 years ago Closed 10 years ago

Disabled radio buttons are smaller than enabled radio buttons

Categories

(Firefox for Android Graveyard :: General, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mfinkle, Assigned: vingtetun)

Details

Attachments

(1 file)

The new web theme might have caused a regression here. Go to a page the enables/disables a group of radio buttons. Toggling the radios enabled state will cause the page layout to change.

I used the bugzilla "add attachment" page. Checking the "[ ] Patch" checkbox causes a group of radio buttons to change enabled state. The radios change size and cause the layout to change.

If this is because of a border size difference, we should be using a transparent border, wit the same width as the enabled state.
Attached patch PatchSplinter Review
The problem came from a wrong padding for disabled "select input type="button". I've also change [disabled="true"] to [disabled] to match forms.css
Assignee: nobody → 21
Attachment #441021 - Flags: review?(mark.finkle)
Attachment #441021 - Flags: review?(mark.finkle) → review+
pushed:
http://hg.mozilla.org/mobile-browser/rev/b2645b7afdad

pushed mobile-1.1:
http://hg.mozilla.org/releases/mobile-1.1/rev/501db1d3a8c8
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Is there a test page that I can verify against, Mark?
Wow, -1 for me not reading the actual report thoroughly enough.

verified FIXED on builds:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2.5pre) Gecko/20100426 Namoroka/3.6.5pre Fennec/1.1a2pre

and

Mozilla/5.0 (X11; U; Linux armv71; Nokia N900; en-US; rv:1.9.3a5pre) Gecko/20100426 Namoroka/3.7a5pre Fennec/1.1a2pre
Status: RESOLVED → VERIFIED
Flags: in-litmus?
This should be a unit test.
Flags: in-testsuite?
Flags: in-litmus?
Flags: in-litmus-
You need to log in before you can comment on or make changes to this bug.