Broken characters spacement when printing

RESOLVED DUPLICATE of bug 490475

Status

()

RESOLVED DUPLICATE of bug 490475
8 years ago
8 years ago

People

(Reporter: adri2000, Unassigned)

Tracking

({testcase})

Trunk
x86
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needs reproducing on trunk linux], URL)

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; fr; rv:1.9.1.9) Gecko/20100402 Ubuntu/9.10 (karmic) Firefox/3.5.9
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.3) Gecko/20091109 Ubuntu/8.04 (hardy) Firefox/3.5.4

On some webpages, the characters spacement becomes odd when printing (that appears on print preview as well), like for example some letters are too close to the next one.
It seems to happen at least with Arial 10pt font and justified text.

Reproducible: Always

Steps to Reproduce:
1. Open http://www.assemblee-nationale.fr/13/amendements/2092/209200005.asp
2. Display print preview
Actual Results:  
It's difficult to read because of characters spacement

Expected Results:  
It's readable and characters spacement is correct
(Reporter)

Comment 1

8 years ago
Created attachment 440776 [details]
screenshot of the problem

Comment 2

8 years ago
So that problem is print(preview)-specific and doesn't happen when browsing?

Print preview on that page works fine (no spacing problems) for me on Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a5pre) Gecko/20100424 Minefield/3.7a5pre, so this could be Linux-specific or caused by something on your system or fixed since Firefox 3.5.

Could you check if this is still a problem in a nightly build (http://nightly.mozilla.org/) and if it is, try to create a small standalone page that reproduces the problem and attach it here?
Keywords: testcase-wanted
Whiteboard: [needs reproducing on trunk linux]
Version: unspecified → 3.5 Branch

Updated

8 years ago
Component: General → Layout: Text
Product: Firefox → Core
QA Contact: general → layout.fonts-and-text
Version: 3.5 Branch → 1.9.1 Branch
(Reporter)

Comment 3

8 years ago
> So that problem is print(preview)-specific and doesn't happen when browsing?
Exactly.

I've just tried the latest nightly build on the same system, and the problem is still there. Here is the exact version I've used: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a5pre) Gecko/20100427 Minefield/3.7a5pre

I'm going to attach a testcase html page.

To be honest, I'm not sure at all this is a bug in Firefox. It might very well be a bug in some font component used by Firefox for text rendering, but I hope that the Firefox developers will be able to at least sort out where is the bug, if not fix it :-)

Thanks!
(Reporter)

Comment 4

8 years ago
Created attachment 441788 [details]
testcase html page

Comment 5

8 years ago
Thanks for the testcase!
Keywords: testcase-wanted → testcase
Version: 1.9.1 Branch → Trunk

Comment 6

8 years ago
Hi,

Any news on this bug and the testcase ? Can someone with enough rights at least confirm it ?

Regards,

Comment 7

8 years ago
This looks to be the same as bug 490475.
(Reporter)

Comment 8

8 years ago
Indeed, it looks like a duplicate, so I'm marking it as such.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 490475
You need to log in before you can comment on or make changes to this bug.