Last Comment Bug 561148 - Startup issue: Shutdown takes a long time for some users (30-40 seconds)
: Startup issue: Shutdown takes a long time for some users (30-40 seconds)
Status: RESOLVED FIXED
: meta, perf
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 542943
Blocks: cuts-startup
  Show dependency treegraph
 
Reported: 2010-04-22 11:19 PDT by Alex Limi (:limi) — Firefox UX Team
Modified: 2011-04-29 14:23 PDT (History)
17 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Alex Limi (:limi) — Firefox UX Team 2010-04-22 11:19:57 PDT
(Note: this is filed as a meta bug as part of the “Paper Cut” bugs since we assume that there are multiple existing bugs related to this behavior. Please make them block this bug.)

Do we think we fixed this? Reported to still be there in 3.6.3, but this may have landed on trunk?

Filing this as a tracking bug, if you know about the relevant bug, please make it block this one.
Comment 1 Jesse Ruderman 2010-04-22 13:49:45 PDT
The fix for bug 542943 took care of slow-shutdown problems for many users, according to http://autonome.wordpress.com/2010/03/19/firefox-performance-update-startup-and-otherwise-march-19-2010/
Comment 2 Marco Bonardo [::mak] 2010-04-22 14:47:17 PDT
With async expiration and no bookmarks hash (both are on trunnk) Places does not have a lot of stuff in shutdown anymore, i suspect in some case (especially users with lots of bookmarks that have short browsing sessions) we could still try to save the bookmarks backup on shutdown, though, it's hard to change this without moving too much toward not having a backup at all, we could maybe check duration of the session and if it's a short navigation session don't try to backup and wait the next one (for long sessions the backup is tried on idle).
The other shutdown task that Places could have is the final flush from temp to disk tables, this is needed for integrity, but we plan to also remove temp tables soon (we have still to convert something to async before).
Comment 3 Marco Bonardo [::mak] 2010-04-22 14:48:42 PDT
PS: the above is not taking in count special preferences like users asking to save a bookmarks.html file at shutdown or clearing history at shutdown, if those users are complaining about long shutdown time, that's not a bug since it's by their explicit request.
Comment 4 [:Cww] 2010-04-30 16:39:58 PDT
I wonder if extensions also do on-shutdown tasks.  Also any disk writing (like making a new bookmark backup) may trigger AV scanning, which I imagine can't help.
Comment 5 Marco Bonardo [::mak] 2010-05-13 03:58:28 PDT
(In reply to comment #4)
> I wonder if extensions also do on-shutdown tasks.

IIRC, i've recently seen a bug where an extension was causing large timeouts, so I think they do, and I suppose in many cases there is more attention toward startup/running perfomances rather than on shutdown.
Comment 6 Alex Limi (:limi) — Firefox UX Team 2011-04-22 20:49:08 PDT
Considering this bug fixed, as bug 542943 seems to be the pathological case that most users were seeing. I also haven't seen a lot of complaints about slow shutdowns lately.

Marco, do you know if there's any way to track this similar to how we track startup time in the wild now?
Comment 7 Marco Bonardo [::mak] 2011-04-23 03:45:12 PDT
hm, well I suppose one could time from the first shutdown notification to the last bit of the program, we could probably file a bug to track these times.
Comment 8 George Carstoiu 2011-04-29 07:33:02 PDT
Mozilla/5.0 (Windows NT 6.1; rv:6.0a1) Gecko/20110428 Firefox/6.0a1

Am I to understand that this issue is no longer present?

I found the following unconfirmed bug 646146, related to slow shutdowns.
Comment 9 Alex Limi (:limi) — Firefox UX Team 2011-04-29 14:23:07 PDT
(In reply to comment #7)
> hm, well I suppose one could time from the first shutdown notification to the
> last bit of the program, we could probably file a bug to track these times.

Filed bug 653831.

Note You need to log in before you can comment on or make changes to this bug.