If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Multi-day recurring event with a fixed count, not displaying.

RESOLVED DUPLICATE of bug 367469

Status

Calendar
Provider: CalDAV
RESOLVED DUPLICATE of bug 367469
8 years ago
8 years ago

People

(Reporter: erwin.rehme, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.8.1.4) Gecko/20070723 Firefox/2.0.0.4
Build Identifier: Lightning 0.9

If I create an event and set the Repeat count to a number, the event does not display. The error console shows:

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [calIIcalProperty.value]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///home/fred/.thunderbird/26vmxej5.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js -> file:///home/fred/.thunderbird/26vmxej5.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calItemBase.js :: anonymous :: line 791"  data: no]
Source File: file:///home/fred/.thunderbird/26vmxej5.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js -> file:///home/fred/.thunderbird/26vmxej5.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calItemBase.js
Line: 791

The event shows up on the Apple iCal client.

The ical data for the event is:

BEGIN:VCALENDAR
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
VERSION:2.0
BEGIN:VTIMEZONE
TZID:America/Denver
X-LIC-LOCATION:America/Denver
BEGIN:DAYLIGHT
TZOFFSETFROM:-0700
TZOFFSETTO:-0600
TZNAME:MDT
DTSTART:19700308T020000
RRULE:FREQ=YEARLY;INTERVAL=1;BYMONTH=3;BYDAY=2SU
END:DAYLIGHT
BEGIN:STANDARD
TZOFFSETFROM:-0600
TZOFFSETTO:-0700
TZNAME:MST
DTSTART:19701101T020000
RRULE:FREQ=YEARLY;INTERVAL=1;BYMONTH=11;BYDAY=1SU
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
CREATED:20100422T200612Z
LAST-MODIFIED:20100422T200632Z
DTSTAMP:20100422T200632Z
UID:d38a4319-d435-4e90-971a-224ceeb29b05
SUMMARY:multiday 3
RRULE:FREQ=DAILY;COUNT=3;INTERVAL=1
DTSTART;TZID=America/Denver:20100423T150000
DTEND;TZID=America/Denver:20100423T160000
X-MOZ-GENERATION:1
X-S1CS-RECURRENCE-UNTIL;VALUE=DATE-TIME:20100425T210000Z
END:VEVENT
END:VCALENDAR


Reproducible: Always

Steps to Reproduce:
1.Create a new event.
2.Select "Custom" from the "Repeat:" menu.
3.Select "Create" in "Range of recurrence".
4.Use the default of 5.
5.Select OK.
6.Save and Close
Actual Results:  
The event does not display in the calendar.

Expected Results:  
All five of the event's instances should show up on the calendar.

Comment 1

8 years ago
This is already fixed in the Lightning 1.0 Beta 1 release.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 367469
You need to log in before you can comment on or make changes to this bug.