Install pyquery dependencies on PAMO, NAMO, SAMO and AMO

RESOLVED FIXED

Status

Infrastructure & Operations
WebOps: Other
RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: clouserw, Assigned: oremj)

Tracking

Details

(Reporter)

Description

8 years ago
We've been using PyQuery on our development boxes for unit tests and we're beginning to use it for our cron jobs too so I moved it to requirements-prod.txt.

It requires lxml and libxml2 to be installed as system packages, before we can install it via pip.

I think it's just those two packages (maybe a -dev package too?), but I don't remember.  I installed what needed to be done on sm-hudson01 back in the day though, and I emailed everything I installed on that box to Shyam so it should be in the sm-hudson IT docs.  Thanks.
(Reporter)

Updated

8 years ago
Blocks: 558926
(Reporter)

Updated

8 years ago
Blocks: 560753
(Assignee)

Comment 1

8 years ago
Do you want me to make an rpm for this?
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> Do you want me to make an rpm for this?

Whatever you need to distribute on the boxes above.  I don't think the developers need it.
(Assignee)

Updated

8 years ago
Assignee: server-ops → jeremy.orem+bugs
(Assignee)

Comment 3

8 years ago
I've built a package for lxml and installed it on preview and khan. It will be installed in production next time puppet is run.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Component: Server Operations: Web Operations → WebOps: Other
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.