Closed Bug 561236 Opened 10 years ago Closed 10 years ago

push_back() causes dependency on libstdc++ from gcc4.5

Categories

(Core :: IPC, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: taras.mozilla, Assigned: taras.mozilla)

References

Details

Attachments

(1 file, 1 obsolete file)

Attached patch crappy workaround (obsolete) — Splinter Review
(list|vector)::push_back can't be used if we dynamically link libstdc++
We should move to gcc4.5 to make use of PGO and (eventually plugins), unfortunately 4.5 will accidentally drag in dependencies on newer stdc++. Luckily only a handful of places in the code used push_back(or list::insert).
Looks like the problem is http://gcc.gnu.org/bugzilla/show_bug.cgi?id=16896 

Looks like so far the backward-compat of our Linux binaries was mostly due to luck. libstdc++ does not guarantee backward compatibility(just forward).

I have had luck with compiling using a libstdc++ from gcc 4.4. Trying to see if i can compile gcc 4.5 with stdc++ from 4.4.
Attached patch gcc 4.5 patchSplinter Review
This patch is the best option for making backward-compatible binaries with 4.5. Modifying code to avoid stl lists sucks. There are a couple more library calls, but i'd rather keep the changes small for now.
Assignee: nobody → tglek
Attachment #440913 - Attachment is obsolete: true
-static-libstdc++ seems like a reasonable workaround
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.