Closed Bug 561299 Opened 10 years ago Closed 10 years ago

Crash [@ js_GetWrappedObject] with WebGLUnsignedIntArray

Categories

(Core :: JavaScript Engine, defect, critical)

x86
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 561566
Tracking Status
blocking2.0 --- betaN+

People

(Reporter: jruderman, Assigned: mrbkap)

References

(Blocks 1 open bug)

Details

(Keywords: crash, testcase)

Crash Data

Attachments

(3 files)

No description provided.
Attached file stack trace
tracking-fennec: --- → ?
blocking2.0: --- → ?
tracking-fennec: ? → ---
Attached patch FixSplinter Review
Easy fix: null is an object. JSVAL_IS_PRIMITIVE censors null for us.
Assignee: general → mrbkap
Status: NEW → ASSIGNED
Attachment #442183 - Flags: review?(vladimir)
Same as bug 561566 -- I've got a r+'d (identical) patch in there, will land it on tm in a sec.
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 561566
blocking2.0: ? → betaN+
Crash Signature: [@ js_GetWrappedObject]
You need to log in before you can comment on or make changes to this bug.