custom setting expander isn't opened when appropriate

VERIFIED FIXED in 1.3b2

Status

VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: wkrakowski, Assigned: mconnor)

Tracking

({regression})

unspecified
1.3b2
regression
Points:
---
Bug Flags:
blocking-weave1.3 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [weave1.3])

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; it; rv:1.9.2.4) Gecko/20100413 Firefox/3.6.4
Build Identifier: 1.3b1

Hello,

I set my custom preferences for syncing info with weave, because I don't want to sync everything.
I closed preferences. When opened preferences again, it was again set to "sync everything"

Reproducible: Always

Steps to Reproduce:
1. Install weave
2. change "browser sync" to "custom settings", choose what you want to sync.
3. Close preferences window and reopen it.
Actual Results:  
Firefox will "sync everything"

Expected Results:  
Firefox will "Use my custom settings"
(Assignee)

Comment 1

8 years ago
Note that if you expand the UI, the unchecked things are still unchecked, we're just not setting the UI up right.
Assignee: nobody → mconnor
Severity: major → normal
Status: UNCONFIRMED → ASSIGNED
Component: General → Firefox UI
Ever confirmed: true
Keywords: regression
OS: Windows 7 → All
QA Contact: general → firefox
Hardware: x86 → All
Summary: Weave won't keep custom sync settings. → custom setting expander isn't opened when appropriate
Whiteboard: [b2]
(Assignee)

Comment 2

8 years ago
Created attachment 441033 [details] [diff] [review]
v1
Attachment #441033 - Flags: review?(edilee)
(Assignee)

Updated

8 years ago
Flags: blocking-weave1.3+
Target Milestone: --- → 1.3
(Reporter)

Comment 3

8 years ago
Yes, if I switch to custom settings then the fields are checked correctly, but closing and reopening prefs switches it back to all, so I couldn't really know it.
Attachment #441033 - Flags: review?(edilee) → review+

Updated

8 years ago
Duplicate of this bug: 561713

Comment 5

8 years ago
(In reply to comment #4)
> *** Bug 561713 has been marked as a duplicate of this bug. ***

Please set 'pref panel' or something in the bug name. I had searched for every bug with that, but not found one, and so created a dupe.
(Assignee)

Comment 6

8 years ago
http://hg.mozilla.org/labs/weave/rev/3f0789abb480
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Updated

8 years ago
Target Milestone: 1.3 → 1.3b2
(Reporter)

Comment 7

8 years ago
Seems fixed in 1.3b2. Thanks
Verified with 1.3b2
Status: RESOLVED → VERIFIED

Updated

8 years ago
Whiteboard: [b2] → [b2], [weave1.3]
What does the whiteboard changes mean?

 Status Whiteboard|[b2]                        |[b2], [weave1.3]
waeve1.3 is what we're using in qa to track what was filed for any of the 1.3 builds.
Whiteboard: [b2], [weave1.3] → [weave1.3]
You need to log in before you can comment on or make changes to this bug.