Some widgets don't fire oncommand when toggled via keys

RESOLVED FIXED in mozilla1.0

Status

()

Core
Event Handling
P3
normal
RESOLVED FIXED
18 years ago
15 years ago

People

(Reporter: Blake Ross, Assigned: Blake Ross)

Tracking

({access})

Trunk
mozilla1.0
x86
Windows 98
access
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: patch, URL)

Attachments

(1 attachment)

(Assignee)

Description

18 years ago
Overview Description:

  oncommand doesn't seem to fire for keypresses, as evidenced by many examples 
in various pref panes.

Steps to Reproduce:
  1) Open the preferences dialog.
  2) Mail and Newsgroups > Address Books
  3) Click "Enable Email Address Collection"
  4) Press spacebar multiple times.
  5) Advanced > Proxies
  6) Click "Direct connection to the Internet"
  7) Press the down arrow key.
  8) Click "Manual proxy configuration" (it should already be checked)

Note: Some of this may only work properly in win32/classic due to different 
platform and theme keybindings.

Actual Results:   In step 4, although the checkbox is properly checked and
                  unchecked as you keep hitting spacebar, the widgets indented
                  below it don't properly enable and disable (as they did when
                  you completed step 3).  In step 6, although the "Manual proxy
                  configuration" radio button is properly checked after
                  pressing the down arrow key, its associated textboxes 
                  (indented below it) don't properly enable and didsable (as
                  they did when you completed step 8).

Expected Results: DoEnabling() is properly called whenever the radiobutton
                  and checkbox get checked (or unchecked), so the associated
                  widgets are properly enabled and disabled upon keypress just
                  as if you clicked on them with the mouse.

Reproducibility: 100%

Occurs in new branch and trunk builds (win98se).

Additional Information:
  John, should either case be valid?  I was under the impression that oncommand 
should include both mouse and keyboard commands.  In the case of step 7, 
though, the keypress is actually going to the top radio button, not the button 
that will become checked.  What do you think about all this?
(Assignee)

Comment 1

18 years ago
In case it wasn't extremely obvious, of course, the radiobutton and checkbox in 
question both have oncommand="doEnabling();"

Comment 2

18 years ago
oncommand is unique to XUL, so this isn't joki's bug.  reassigning to saari.
Assignee: joki → saari

Comment 3

18 years ago
This isn't "keys don't fire oncommand", it is "some widgets don't fire oncommand
when toggled via keys".
Status: NEW → ASSIGNED
(Assignee)

Comment 4

18 years ago
correct.
Summary: oncommand not firing for keypresses → Some widgets don't fire oncommand when toggled via keys

Comment 5

18 years ago
mozilla 1.0
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 6

17 years ago
*** Bug 64181 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
Copying from dup: access keyword, blocks bug 18575.
Blocks: 18575
Keywords: access

Updated

17 years ago
Keywords: nsbeta1
Reassigning QA Contact for all open and unverified bugs previously under Lorca's
care to Gerardo as per phone conversation this morning.
QA Contact: lorca → gerardok

Comment 9

17 years ago
clearing target for re-triage, nominating for moz0.9.2. Chris, do you know how 
much work/risk this would entail?
Keywords: mozilla0.9.2
Target Milestone: mozilla1.0 → ---

Comment 10

17 years ago
Well, have to figure out which widgets don't fire it and copy and paste the code
from those that do. It shouldn't be hard.

Comment 11

17 years ago
When you use the arrow keys to move around in a groupbox, the focused 
item should change just as the selected item does.

In radio.xml, I tried to do this.focusedItem = groupElements[index], but it 
didn't seem to change the focus.

I imagine this could easily be fixed when the oncommand stuff is fixed (maybe 
they're related).  If they're not related, I can file a new bug.

Updated

17 years ago
Target Milestone: --- → mozilla0.9.3

Comment 12

17 years ago
Created attachment 36766 [details] [diff] [review]
XBL patch

Updated

17 years ago
Whiteboard: patch

Comment 13

17 years ago
QA contact updated
QA Contact: gerardok → madhur
(Assignee)

Comment 14

17 years ago
Fix is in bug 83614.
Assignee: saari → blake
Status: ASSIGNED → NEW
(Assignee)

Comment 15

17 years ago
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 16

17 years ago
verified on build 2001-07-13-07-trunk
Status: RESOLVED → VERIFIED

Comment 17

17 years ago
Reopening because I'm seeing 2 command events pressing space on a checkbox.
I think that the diff for 1.3 of checkbox.xml should be backed out.
http://www.nrr.co.uk/checkbox.xul is my test case.
tingley@sundell.net on #mozilla agreed that pressing space dumps 2 "Ouch!"es.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Updated

17 years ago
Target Milestone: mozilla0.9.3 → mozilla0.9.5

Updated

17 years ago
Target Milestone: mozilla0.9.5 → mozilla0.9.6

Comment 18

17 years ago
->0.9.6

Updated

17 years ago
Blocks: 104166
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.6 → mozilla1.0
(Assignee)

Comment 19

16 years ago
File a new bug.
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → FIXED

Updated

16 years ago
QA Contact: madhur → rakeshmishra

Updated

15 years ago
QA Contact: rakeshmishra → trix
You need to log in before you can comment on or make changes to this bug.