Autolinkification needs to do lookahead for the string " [details]" with attachments

RESOLVED DUPLICATE of bug 474766

Status

()

Bugzilla
Creating/Changing Bugs
RESOLVED DUPLICATE of bug 474766
8 years ago
8 years ago

People

(Reporter: crussell, Unassigned)

Tracking

Details

Steps to reproduce:
1. In a bugzilla comment, quote something containing an autolinkified attachment.

Expected Results:

Since the quoted string already contains " [details]", that should be the used as the anchor text for the attachment details.

Actual Results:

Autolinkifier indiscriminately inserts its own anchor immediately following the attachment id, resulting in "attachment ###### [details] [details]". E.g.:

> (From update of attachment 439836 [details] [diff] [review])
Assignee: nobody → create-and-change
Component: Bugzilla: Other b.m.o Issues → Creating/Changing Bugs
Product: mozilla.org → Bugzilla
QA Contact: other-bmo-issues → default-qa
Version: other → 3.4.6

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 474766
You need to log in before you can comment on or make changes to this bug.