Theme doesn't dynamically switch on sync to default theme

RESOLVED FIXED in 1.3b4

Status

Cloud Services
Firefox Sync: Backend
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: tracy, Assigned: mconnor)

Tracking

unspecified
1.3b4
Points:
---
Bug Flags:
blocking-weave1.3 +
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: weave1.3b1)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
1) have two machines synced to the same persona.
2) on client A. switch theme back to default, Sync
3) Sync client B.  

Test results: 
Initial window not updated to default theme.  (subsequent windows or on restart
displays default theme)

Expected result:
Dynamic update to default theme

related to bug 558191
(Reporter)

Updated

8 years ago
Flags: blocking-weave1.3?
(Assignee)

Updated

8 years ago
Assignee: nobody → mconnor
Flags: blocking-weave1.3? → blocking-weave1.3+
Target Milestone: --- → 1.3b4
(Assignee)

Comment 1

8 years ago
Created attachment 443169 [details] [diff] [review]
v1

This also eliminates the flash when syncing prefs with a persona applied already.
Attachment #443169 - Flags: review?(edilee)

Updated

8 years ago
Attachment #443169 - Flags: review?(edilee) → review+
(Assignee)

Comment 2

8 years ago
http://hg.mozilla.org/labs/weave/rev/51aa19d42cce
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 3

8 years ago
Investigating this bug for being potential crossweave automation test case
candidate.
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.