Closed Bug 561460 Opened 12 years ago Closed 12 years ago

test_csputils.js is broken

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: bsterne, Assigned: geekboy)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

s: moz2-linux-slave28
TEST-UNEXPECTED-FAIL | /builds/slave/mozilla-central-linux-opt-unittest-xpcshell/build/xpcshell/tests/content/unit/test_csputils.js | test failed (with xpcshell return code: 0), see following log:
Bug 560197 - [xpcshell-tests] Intermittent timeout after test_csputils.js, when running test_error_codes.js
TEST-UNEXPECTED-FAIL | /builds/slave/mozilla-central-linux-opt-unittest-xpcshell/build/xpcshell/tests/content/unit/test_csputils.js | null == com - See following stack:

This appears to be a regression from:
http://hg.mozilla.org/mozilla-central/rev/426165b08c0c
This looks pretty straightforward based on the build log.

in test_csputils.js:

106     h = CSPHost.fromString("com");
107     do_check_eq(null, h); // "lone symbol should fail"

This should pass and not be null, since the host is parsed as "com" due to the check-in of bug 524066:

107     do_check_neq(null, h); // "lone symbol should not fail"

This one-character change should fix the bustage.
Whiteboard: [orange]
Attached patch fixSplinter Review
Attachment #441180 - Flags: review?(sstamm)
I tested the fix and the test passes now.
Attachment #441180 - Flags: review?(sstamm) → review+
Is this bug fixed then?
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Blocks: 438871
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.