Autocomplete containing no forward-slash duplicates letters

RESOLVED FIXED

Status

Skywriter
Command Line
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Adam, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.4) Gecko/20100413 Firefox/3.6.4 (.NET CLR 3.5.30729)
Build Identifier: Main Bespin Server "undefined" version

Command autocompletion that involves filenames without an initial forward-slash generates matches, even though they are not valid. Also, it duplicates the last-entered letter when autocompleting. For instance, entering "open SampleProject/ind" and pressing tab will result in "open SampleProject/inddex.html", despite the 'correct' entry of "open SampleProject/index.html" returning a file not found error.

Reproducible: Always

Steps to Reproduce:
1. Navigate to the command line.
2. Enter "open SampleProject/ind" and and press tab to autocomplete, then Enter to
execute.
3. Witness the 404 as Bespin attempts to open /SampleProject/inddex.html
4. Retry the command by manually entering "open SampleProject/index.html" and realize that it generates a 404 as well.
Actual Results:  
"Unable to open the file (Server returned 404)."

Expected Results:  
Either accept filenames/paths without a preceding forward slash and not duplicate letters when autocompleting, or remove autocompletion of filenames/paths without a preceding forward slash.
(Reporter)

Updated

8 years ago
Summary: Autocomplete containing forward-slash duplicates letters → Autocomplete containing no forward-slash duplicates letters
(Reporter)

Comment 1

8 years ago
Looks like this was fixed with the new Autocomplete functionality.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.