Make all/normal headers showing toggleable dynamically

RESOLVED WONTFIX

Status

Thunderbird
General
--
enhancement
RESOLVED WONTFIX
8 years ago
8 years ago

People

(Reporter: Ryan Li, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a5pre) Gecko/20100421 Minefield/3.7a5pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a5pre) Gecko/20100424 Shredder/3.2a1pre

Thunderbird provides the option whether to show all/normal message headers.
However, when all headers are displayed, the information bar becomes way too long, and takes a large amount of space, having a bad effect on daily use.
There is a solution to eliminate this option and provide better usability: use an expander (something like Gtk::Expander) in the headers, and show `normal' headers by default. so that when the user wants to view all headers, he/she could just click the expander.

Reproducible: Always
(Reporter)

Comment 1

8 years ago
Created attachment 441326 [details]
A screenshot of the headers when all are shown.

This effectively prevents message content to be shown. Notice the scroll bar on the right.
I'm pretty sure their an extension that does that https://addons.mozilla.org/en-US/thunderbird/addon/13564
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

8 years ago
But this is an add-on, not built-in functionality. And it doesn't work well under GNOME with 3.2a1pre, looks ugly.
So what's the reason for not having this feature built-in?
You need to log in before you can comment on or make changes to this bug.