Thunderbird hangs when indexing mail. This problem disappears when Global Search and Indexing is switched off

RESOLVED WORKSFORME

Status

defect
--
critical
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: mckaymeister, Unassigned)

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [has stacktrace][needs gloda debug info])

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.1.9) Gecko/20100317 Lightning/1.0b1 Thunderbird/3.0.4

Thunderbird was hanging when Indexing.  Searched the forum and follewd the instructions in https://wiki.mozilla.org/Thunderbird:Testing:Memory_Usage_Problems to step 9.  This states that if problem is solved file a bug report. With Global Search and Inexing switched off Thunderbird no longer hangs

Reproducible: Always
Is CPU high, low or zero?  Please attach a stacktrace file to bug using instructions at
  analyze -v -hang 
on https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg
Keywords: hang, stackwanted
Version: unspecified → 3.0
CPU averaging 25%.
I had a bit of difficulty producing the stacktrace so I'm not sure if it was done correctly.  I'm happy to be contacted if the trace is wrong.
Keywords: stackwanted
Whiteboard: [has stacktrace]
It looks like we're evaluating JS, according to the stack. Is the UI really hung? Can you select other folders? If it's truly not responsive, how long have you tried waiting? And is there anything on the error console? (I doubt there is, but we have to ask)

Wayne, perhaps gloda logging could help.
I set the Global Indexing on and got Thunderbird to hang.  It lasted about 40 seconds.  This I would say is shorter than previous.  When thunderbird hangs I cannot access any other folders and the window label shows (Not Responding) after the label "Inbox MozillaThunderbird and the Windows cursor shows the rotating wheel.

I opened the error console and it showed the following error message:

Error: [Exception... "Component returned failure code: 0x80004001 (NS_ERROR_NOT_IMPLEMENTED) [nsIRequest.name]"  nsresult: "0x80004001 (NS_ERROR_NOT_IMPLEMENTED)"  location: "JS frame :: file:///C:/Program%20Files%20(x86)/Mozilla%20Thunderbird/components/nsLoginManager.js :: anonymous :: line 328"  data: no]
Source File: file:///C:/Program%20Files%20(x86)/Mozilla%20Thunderbird/components/nsLoginManager.js
Line: 328
Ok, can you follow the first two steps at https://developer.mozilla.org/en/Thunderbird/Gloda_debugging, this should show you more errors in the error console.
(In reply to comment #5)
> Ok, can you follow the first two steps at
> https://developer.mozilla.org/en/Thunderbird/Gloda_debugging, this should show
> you more errors in the error console.

Scotsmac, do you still see the issue if you run version 3.1.4 with gloda enabled?
Component: Folder and Message Lists → Search
QA Contact: folders-message-lists → search
Whiteboard: [has stacktrace] → [has stacktrace][needs gloda debug info]
Same problem (and same solution) with:
Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.2.13) Gecko/20101207 Lightning/1.0b2 Thunderbird/3.1.7

Info message from error console:
2011-01-20 18:07:30	gloda.index_msg	ERROR	Exception while attempting to mark message with gloda state afterdb commit [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIMsgDBHdr.getUint32Property]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: file:///D:/xxxx/Moz_TH/modules/gloda/index_msg.js :: PendingCommitTracker_commitCallback :: line 173"  data: no]
I've been using Thunderbird 3.1.7 with Global Search and Indexing
enabled and have had no problems for sometime.
Thanks Scotsmac
WFM per reporter.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.